Once an address is collected a shorter address which includes the start of this address cannot be entered to a 'To' or 'Cc' field.

RESOLVED DUPLICATE of bug 412686

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 412686
8 years ago
8 years ago

People

(Reporter: robsoles, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.2 (KHTML, like Gecko) Chrome/5.0.342.9 Safari/533.2
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9) Gecko/20100423 Thunderbird/3.0.4

I sent an email to support@tp-link.com.au and they ignored it, when I went to forward the email to a range of addresses on their domains I found a problem.

Every time I tried to enter 'support@tp-link.com' into a 'To' or 'Cc' field it was adjusted to 'support@tp-link.com.au' every time I left the field, no matter how I took focus off the field.

I got around this by deleting the collected address from the address book though I had to trash my first 'forward' edit and click 'forward' on the original in my sent items before I could benefit from deleting it.

About "Auto-Correction": If the software 'corrects' a mistake the human made and the human immediately goes and "un-corrects" it the software should recognise to leave the blasted thing alone now!

Reproducible: Always

Steps to Reproduce:
1. Allow address book to collect an email address from which another, just as valid, email address can be made by removing some letters at the end.
2. Try typing the shorter address into a composition's (hit 'write') 'to' or 'cc' field
3. Move focus/selection away from that field - hey presto. Dumbness ensues.
Actual Results:  
The perfectly correct address was corrected to a perfectly correct other address that was not desired at the time.

Expected Results:  
I would be able to enter a valid enough email address and have it unmolested, particularly after re-correcting it, even though it may look like the start of a longer address used previously.
Whiteboard: dupeme
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 412686
You need to log in before you can comment on or make changes to this bug.