Incorrect address-to-name mapping

RESOLVED DUPLICATE of bug 474721

Status

RESOLVED DUPLICATE of bug 474721
9 years ago
9 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.2.3) Gecko/20100403 Firefox/3.6.3
Build Identifier: 

If a message has a recipient address without real name and this address is known in the address book, the corresponding real name is displayed - fine. But this real name is also shown when the recipient contains a real name part. Sounds complicated but look below.

Reproducible: Always

Steps to Reproduce:
1. create an address book entry "Joe User" <joe.user@foo.bar>
2. send a message to yourself, CC to "Someone Else" <joe.user@foo.bar>
3.
Actual Results:  
The CC field shows "Joe User"

Expected Results:  
It should show "Someone Else" <joe.user@foo.bar>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474721
You need to log in before you can comment on or make changes to this bug.