Thunderbird becomes unresponsive for few seconds, while a response to an invitation is being send back

RESOLVED WORKSFORME

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Makpoc, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9) Gecko/20100423 Lightning/1.0b1 Thunderbird/3.0.4

When I accept or decline a invitation, that I've received via e-mail in thunderbird 3.0.4 a window pops up, that's giving me the choice to send back a response. If I choose to send one Thunderbird becomes unresponsive for 4-5 seconds (I assume - while the response is being handled)

Reproducible: Always

Steps to Reproduce:
1. Receive a mail containing calendar invitation
2. Accept it
3. Choose to send an response about the acceptance (i'm not selecting 2000 compatibility, but I suppose it doesn't matter anyway)
Actual Results:  
Thunderbird becomes unresponsive for few seconds (presumably while the response is being send)

Expected Results:  
response should be send in a different thread so that it does not block further user's interaction with Thunderbird
(Reporter)

Comment 1

8 years ago
I'm changing the product and component information as this seems to be applicable for sending a mail in general.
Component: Lightning Only → General
Product: Calendar → Thunderbird
Version: unspecified → 3.0
QA Contact: lightning → general

Comment 2

8 years ago
Hello,

I've got a similar problem (not the same).

I've got many calendars on the internet (http://www.icalx.com) that I use in Lightning.

When I receive an invitation, that I've received via e-mail with an .ics file attached, when I open the mail, there are 3 buttons : accept, Refuse, Try.
When I try to accept it, a popup appears :
In wich agenda do you want to import these elements ?"

But no agenda is displayed. The window doesn't contain any calendar, and the OK button (in the bottom) is grayed.


User-Agent: Thunderbird 2.0.0.24 Lightning 0.9
Build Identifier: Thunderbird (build 20100228) Lightning (build 2008091719)

Reproducible: Always

Steps to Reproduce:
1. Receive a mail containing invitation (meeting...)
2. Try to accept it in a known calendar

Expected Results:  
the calendar selection should present to available calendars, event if they are away on the network, so that the import of the notification is allowed.
Component: General → Lightning Only
Product: Thunderbird → Calendar
QA Contact: general → lightning
Version: 3.0 → unspecified
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)

Comment 3

3 years ago
Makpoc, is this still an issue with Lightning 3.3.x?
(Reporter)

Comment 4

3 years ago
(In reply to MakeMyDay from comment #3)
> Makpoc, is this still an issue with Lightning 3.3.x?

Hi,

I'm unable to reproduce this with thunderbird 31.1.1 and Lightning 3.3.

I'm not sure if this is relevant, but I've moved to different distribution and I'm also using Exchange provider, so my setup is not the same as it was at the time this issue was reported.

Comment 5

3 years ago
Resolving this to WFM as per comment #4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.