Add-on with two "Continue to Download" buttons

VERIFIED DUPLICATE of bug 538259

Status

P5
normal
VERIFIED DUPLICATE of bug 538259
9 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

unspecified
4.x (triaged)
x86
macOS

Details

(Whiteboard: [z][button], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 446243 [details]
screenshot

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

steps to reproduce:
go to https://preview.addons.mozilla.org/en-US/firefox/addon/87458/

observed behavior:
Add-on has two "Continue to download" buttons.See screenshot

selection source:
 <a class="button contrib go prominent  installer" data-hash="sha256:737d41737c322a6f8fb0730e92d3093ecaf35397da50e33d28cf5ada5d02ab75" href="/en-US/firefox/addon/87458/developers/roadblock?src=addondetail">
 <b></b>

<span>
Continue to Download&nbsp;→
 </span>
</a>
 <a class="button contrib go prominent  installer" data-hash="sha256:737d41737c322a6f8fb0730e92d3093ecaf35397da50e33d28cf5ada5d02ab75" href="/en-US/firefox/addon/87458/developers/roadblock?src=addondetail">
<b></b>
<span>
Continue to Download&nbsp;→
</span>

 </a>
(Reporter)

Updated

9 years ago
Summary: Add-on with double "Continue to Download" buttons → Add-on with two "Continue to Download" buttons
The add-on has 2 identical public files under the same version, probably due to an upload error: https://preview.addons.mozilla.org/en-US/admin/addons?q=[87458]

I've corrected the add-on status in production by disabling one of the files. I think that should correct the button issue for that add-on.

I guess the bug is about handling this edge case more gracefully, so I'm not changing its status.
(In reply to comment #1)
> I guess the bug is about handling this edge case more gracefully, so I'm not
> changing its status.

It's a data problem, but we should see if the buttons can handle it a little better.  Thanks for fixing the add-on Jorge.
Priority: -- → P5
Target Milestone: 5.11 → 4.x (triaged)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538259
(Reporter)

Comment 4

9 years ago
verified
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.