Tab Candy isn't listed in Add-ons manager's "Extensions" list at first. (Can't uninstall / disable / check version)

RESOLVED DUPLICATE of bug 566626

Status

defect
RESOLVED DUPLICATE of bug 566626
9 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STEPS TO REPRODUCE:
 1. Start Firefox (with a fresh profile, for simplicity)
 2. Drag and drop tabcandy.xpi file onto it, to install.
 3. Restart Firefox.
   --> Note that the tab candy icon is there in your icons bar.
 4. Go to Tools|Add-ons, or visit about:addons
   --> TabCandy isn't listed in extensions!!!
 5. In left pane of Add-ons manager, click "Themes" bar, and then back to "Extensions"
   --> Now TabCandy is listed.

EXPECTED RESULTS: TabCandy should be listed in the extensions list, after step 4.

I'm using TabCandy version 0.3.1, downloaded yesterday from http://hg.mozilla.org/labs/tabcandy/raw-file/tip/tabcandy.xpi .  The XPI md5sum is 314a23a70d7edba47405ffaff38f5370

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100519 Minefield/3.7a5pre
(In reply to comment #0)
> STEPS TO REPRODUCE:
>  1. Start Firefox (with a fresh profile, for simplicity)

er, s/Firefox/a mozilla-central nightly/ (that's all I've tested)
Posted video screencast of bug
Here's a screencast demonstrating the bug (in a fresh profile, with tab candy installed).
AFAICT, once tab candy shows up in addons manager, it stays there for the remainder of that Firefox session -- but when I restart Firefox, it's gone again.

Also: As an alternative to Step 5 from comment 0, I can also make TabCandy appear in the list by clicking the "refresh" button when I'm in Add-ons manager.
Sounds like Bug 566626
Yup, sounds like the same thing.  I hadn't noticed this affecting other addons, but now that you mention it, this does seem to affect NoScript on my machine too (as described in bug 566626).

Marking as dupe.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566626
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.