generated xpis throw in harness.js

RESOLVED DUPLICATE of bug 566812

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 566812
8 years ago
8 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXPCComponents_Utils.import]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: file:///home/dietrich/.mozilla/firefox/6tufclur.asd/extensions/jid0-8O4s3e05BbNHwNUDpsDIOhQcF5w@jetpack/components/harness.js  :: buildLoader :: line 170"

Same error in 3.6 and trunk.
Same error with real module content, or just a console.log("hello world");
Blocks: 566904
Atul: any thoughts on what might be going on here?

Comment 2

8 years ago
I believe this is the error generated by applying attachment 446297 [details] [diff] [review] from bug 566812 to the trunk. It proves that the patch doesn't work, as it merely fixes one problem while running into another one (which I explain in bug 566812 comment 13).

As such, I'm going to go ahead and mark this bug as a duplicate of bug 566812, so they remain linked at least.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566812
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.