Opening a new tab is on the left toolbar with unsorted tab container

RESOLVED WORKSFORME

Status

Firefox Graveyard
Panorama
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: tchung, Assigned: iangilman)

Tracking

Trunk
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 446410 [details]
New Tab Window on Left screenshot

If the tab container has unsorted webpages in it, then clicking on the "new tab" icon i the bottom left corner will prompt a New Tab in the first location of the tab toolbar, not the last.   

Other situations always seem to put the new tab at the end of the open tabs 

See screenshot

Repro:
1) install tab candy alpha
2) have a tab container with ungrouped items
3) click the "new tab" icon
4) Verify a new tab opens as the first tab item, not the last.  New tabs should always be last in the tab list.

Expected:
- opened new tab is last item on tab bar
(Assignee)

Comment 1

8 years ago
To translate into the terminology we've been using during development: when you hit the "new tab" button of a stacked group, the new tab appears at the left end of that group's tab bar. If the group is not stacked, it'll appear at the right end. 

This is a natural consequence of our putting new tabs for stacked groups at the top of the stack. A couple thoughts: 

- Perhaps the top of the stack should be the last item in a group rather than the first?

- Now that we're temporarily placing the last page you visited at the top of the stack, we can put new tabs at the end of the group and you'll still see it at the top of the stack, no matter which way the stack is sorted. 

Assigning to Aza for design.
Assignee: nobody → aza

Comment 2

8 years ago
(In reply to comment #1)
Hello, I'm reply to you. You will be confused.
(In reply to comment #2)

Testing confusion levels

Comment 4

8 years ago
(In reply to comment #3)
Sorry about that, I was showing off http://bugzilla.azarask.in at the Mozilla all-hands meeting and needed a quick place to demonstrate commenting.

Updated

8 years ago
Duplicate of this bug: 574770

Comment 6

8 years ago
(In reply to comment #1)
* The top item in a stack should still be the first item in a group or the last seen item
* New tabs go at the end of the group and tab-strip if created using the new-tab button (although appear at the top of the a stacked group) or via command-t when TabCandy is open.
* If you are in a group (i.e., a tab-strip is shown) and you open a new tab via command-t or a link, it gets placed where Firefox would place it if TabCandy doesn't exist (so either at the end of the strip or next to the tab depending on preferences).

Updated

8 years ago
Assignee: aza → ian

Comment 7

7 years ago
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Component: TabCandy → TabCandy
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk

Updated

7 years ago
QA Contact: tabcandy → tabcandy

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.