Android builds do not run on ARMv5 or ARMv6 processors

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Michael Malutin, Unassigned)

Tracking

Trunk
ARM
Android
Dependency tree / graph

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mobile-trunk/fennec.apk

see log file
adb logcat

Reproducible: Always
(Reporter)

Updated

8 years ago
OS: Other → Android
(Reporter)

Comment 1

8 years ago
Created attachment 446480 [details]
adb logcat > fenec2.log

Comment 2

8 years ago
What device are you testing on?
(Reporter)

Comment 3

8 years ago
HTC Magic.
Kernel 2.6.33.4-cyanogenmod
Mod version: CyanogenMod-5.0.7-DS-test5

Comment 4

8 years ago
https://wiki.mozilla.org/Mobile/Platforms/Android#System_Requirements

Current Fennec builds will not run on these devices:

    * Android SDK emulator
    * HTC Dream (T-Mobile G1, Android Dev Phone 1)
    * HTC Droid Eris
    * HTC Hero (T-Mobile G2 Touch)
    * HTC Magic (T-Mobile myTouch 3G, T-Mobile G1 Touch)
    * HTC Tattoo
    * Samsung Moment
Hardware: Other → ARM
Summary: Application crush on start at Android 2.1-update1 → Android builds do not run on ARMv5 or ARMv6 processors

Updated

8 years ago
Duplicate of this bug: 571912
Status: UNCONFIRMED → NEW
Ever confirmed: true
tracking-fennec: --- → ?
blocking fennec 2.0+ to either start producing ARMv5 builds in parallel or decide that we're not supporting ARMv5 and ARMv6
tracking-fennec: ? → 2.0+
Depends on: 577531

Comment 7

8 years ago
Fennec for Android?

moar like Fennec for ARMv7
Is bug 577531 the only thing blocking support for v5 and v6? Or are there other things as well?
thumb2 builds are smaller and faster than non-thumb builds, so that's what we want to ship IMO. The thinking is that we can have a separate build for ARMv5 and ARMv6 support.
Ah, so size is the only concrete problem preventing Fennec on ARMv5/6?

Comment 11

7 years ago
(In reply to comment #10)
> Ah, so size is the only concrete problem preventing Fennec on ARMv5/6?

Mostly if you have a G1. I think other devices had more space. I suppose you could get some firmware that allows installing to SD card for the G1 and make it work.
(In reply to comment #11)
> (In reply to comment #10)
> > Ah, so size is the only concrete problem preventing Fennec on ARMv5/6?
> 
> Mostly if you have a G1. I think other devices had more space. I suppose you
> could get some firmware that allows installing to SD card for the G1 and make
> it work.

Many of the devices on the unsupported list on the wiki have better hardware than the G1, but not as good as, say, the Nexus One. I have an HTC Wildfire, and Fennec didn't start (528mhz, ARMv6, 384mb RAM, 512mb ROM). However, I didn't try installing to the SD card. Will try that next.
Depends on: 586772
with Bug 586772 fixed, I can run those Fennec builds on my G1 with CyanogenMod 5.0.8 (2.1 Eclair) installed.
It is even pretty fast, but: even if Fennec is installed on the sd card, after around 2 minutes of using it, it consumes all available internal memory and crashes to the home screen...

Comment 14

7 years ago
Hello.

First : https://wiki.mozilla.org/Mobile/Platforms/Android#System_Requirements
 -> MozillaWiki has a problem

Second : as Dietrich, on my HTC wildfire/android 2.1 [Fr] , Fennec didn't start.
I join my ddm-log-1.txt , exported from DDM.

Comment 15

7 years ago
Created attachment 469956 [details]
Log from ddms ( under linux mandriva ) during launching Fennec alpha on HTC wildfire/android 2.1 [Fr].
alpha 1 supports ARMv7 or greater

Comment 17

7 years ago
(In reply to comment #16)
> alpha 1 supports ARMv7 or greater

HTC ( http://www.htc.com/fr/product/wildfire/specification.html ) do not specify the proc ;(
So I suppose is *not* ARMv7 or greater..
Cheers.
See https://wiki.mozilla.org/Mobile/Platforms/Android for links to nightly builds for Wildfire and other ARMv6 devices.
Duplicate of this bug: 591499

Comment 20

7 years ago
Thank Matt.
Nightly build run on HTC wildfire/android 2.1 ;)
But is very slow regarding Dolphin HD browser.
Duplicate of this bug: 591394
Duplicate of this bug: 592211

Comment 23

7 years ago
Is phone popularity a factor in this decision or is it just technical-based? I can buy some market data telling us which are the most popular Android phones (with actual numbers) in markets like the US, UK, FR, DE. Knowing how relevant this data is will help me decide whether to buy or not.
There are technical reasons that we prefer ARMv7, mostly for the thumb2 support. Market reasons do come into play though, for instance f there is an ARMv6 device that we run well on and is very popular then that's a reason to consider supporting ARMv6. Otherwise ARMv7 and greater is the preference.

Comment 25

7 years ago
ARMv6 alpha is now successfully running on HTC Legend with 2.1 (Eclair) (last time I checked, about three or four weeks ago it wasn't).

That being said, I will file bug reports on a few issues with it, that might also affect the ARMv7 beta.
WFM, since the nothumb builds run on ARMv6 devices
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 27

7 years ago
Lates build for today doesnt work for me:

HTC Magic.
Kernel 2.6.35.7-cyanogenmod
Mod version: CyanogenMod-6.1.0-RC1-DS

I start the application but It returns to the home screen without any warning

Comment 28

7 years ago
I'm still not seeing this work on the HTC Hero.
There seems to be a regression in ARMv6 builds sometime in the last month.  Someone seeing this issue should open a new bug for it, along with any relevant stacks or logcat output.

Comment 30

7 years ago
Is that in regards to the lack of HTC Hero support? I really am not proficient enough with android to provide anything like stack-traces. I simply know that all I get is a black screen. I've also noticed the installer is incredibly huge.

Comment 31

7 years ago
I believe that HTC Magic is the same as the T-Mobile myTouch 3G which I have running Android 2.2.1 Baseband 62.50sj.20.17u_2.22.28.25 Kernal 2.6.32.9-27237-gbe746fb Build FRG83D. After loading the ARMv6 Fennec (ARMv7 reports that the phone does not have the right properties), the phone locks up. The only solution is a cold boot by removing the battery. I tried this three times with the same result. In order to use the phone, I had to quickly uninstall Fennec before it loaded itself and shut down the phone. ARMv6 should not be installed on a T-Mobile myTouch 3G running Froyo.

Comment 32

7 years ago
the nightly build silently crashes upon launch on my Samsung I5800 Galaxy 3 (OS Version : 2.2 ; Firmware Version : I5800XXJPA ; CPU ISA : ARMv6).

Comment 33

7 years ago
(or the device just completely freezes)

Comment 34

7 years ago
The current ARMv6 nightly build loads on the Motorola Backflip, but after less than a half minute of usage, the memory consumption suddenly seems to skyrocket from roughly 30MB to beyond 80MB (the max. free RAM I had available) and crashes.

Comment 35

7 years ago
Has anyone tried the ARM 6 build on Samsung Intercept...?

Comment 36

7 years ago
I ran the latest ARMv6 build on my Samsung Intercept (Virgin Mobile USA).
(OS: 2.1 ; Firmware: 2.1-update1 ; Kernel: 2.6.29 ; Hardware: M910.05)

Upon running it, Fennec closes and offers the Mozilla Crash Reporting screen. Once I close that, the OS alerts me that Fennec isn't responding and force closes it.

Comment 37

7 years ago
The latest ARMv6 build lasts significantly longer on the Motorola Backflip before crashing (likely again due to memory problems), although when I tried loading google.com the tab reportedly crashed, so the welcome page was the only one I was able to see.

Comment 38

7 years ago
I tried to run the 
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-r7-nothumb/fennec-4.0b4pre.en-US.eabi-arm.apk 
downloaded at 2010-12-27 06:54(UTC+0) on a:

Orange San Francisco (aka ZTE Blade), OS 2.1-update1, kernel 2.6.29 zte-kernel@Zdroid-SMT, build OUK_P729BV1.0.0B08

Upon running it, the device returns immediately to the homescreen.  No messages or errors, and Task Manager doesn't show it as still running.

Comment 39

7 years ago
FYI,
I tried installing this on my HTC Droid Eris yesterday and got the error message "the item you requested cannot be found". I am running Android 2.1 so I cannot get the build to even try to install. If I can provide any further info about my phone please let me know what you guys need to know.
I am with HTC Dream - The developer phone and it's not working. It loads, shows for 2 sec the initial screen and then it goes back to the android's main screen.
Same here with the HTC Magic.
You need to log in before you can comment on or make changes to this bug.