Session restore not working with Browsing History set to clear

RESOLVED DUPLICATE of bug 398817

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 398817
8 years ago
8 years ago

People

(Reporter: Stephane V., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729) Creative ZENcast v2.00.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729) Creative ZENcast v2.00.13

I'm not too much of a technical type, but here's what happens:

Privacy settings are set to clear the Browsing History after Firefox is closed, but when multiple tabs are open when closing Firefox, it asks if we want to remember open tabs for next session.

If you click "Save & Quit", it does NOT remember, since the Browsing History is probably cleared after this selection, without keeping those tabs in memory.

Browser should present a warning if user chooses to save session, but ALLOW his to restore previous session's tabs with correct browsing history (after all, what's the point in asking, if it's not going to do it?).

Browsing History would be cleared completely BUT for the opened tabs' URLs, that could be kept in History or in a special file to allow session restore.

Thank you!


Reproducible: Always

Steps to Reproduce:
1. Click on "Tools / Options / Privacy / Settings"
2. Check the "Browsing History" box to clear its content when Firefox closes
3. Open multiple URLs in different tabs
4. Quit Firefox : it will ask you if you want to remember those tabs for next session
5. Reopen Firefox : no tabs were saved at all!
Actual Results:  
See Step #5

Expected Results:  
Saved tabs history (at least the LAST page on display) should be saved and restored when reopening Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398817
You need to log in before you can comment on or make changes to this bug.