Crash in [@ @0x0 | mozilla::WebGLContext::SetDimensions(int, int) ]

RESOLVED FIXED

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Seen while running Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100519 Minefield/3.7a5pre. Not able to repro on Win XP using same build.

STR:
1. Load the site in the url. Crash. 100% reproducible on Windows 7

Frame  	Module  	Signature [Expand]  	Source
0 		@0x0 	
1 	xul.dll 	mozilla::WebGLContext::SetDimensions 	content/canvas/src/WebGLContext.cpp:138
2 	xul.dll 	nsHTMLCanvasElement::UpdateContext 	content/html/content/src/nsHTMLCanvasElement.cpp:355
3 	xul.dll 	nsHTMLCanvasElement::GetContext 	content/html/content/src/nsHTMLCanvasElement.cpp:332
4 	xul.dll 	nsIDOMHTMLCanvasElement_GetContext 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:17082
5 	mozjs.dll 	js_Interpret 	js/src/jsops.cpp:2199
6 	mozjs.dll 	js_Invoke 	js/src/jsinterp.cpp:831
7 	mozjs.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:882
8 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4922
9 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2180
10 	xul.dll 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:228
11 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1085
12 	xul.dll 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1181
13 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:628

Will try to find a regression range.
http://www.peternitsch.net/demo/webgl/index.html is another site that shows up in crash stats that also crashes 100%
I suspect "webgl.enabled_for_all_sites" should be "True".  No crashes for me either way.  I'm using 32 bit so maybe its a 64 bit bug (WOW64).

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100519 Minefield/3.7a5pre

Updated

8 years ago
OS: Windows 7 → Mac OS X

Updated

8 years ago
OS: Mac OS X → Windows 7
I'm pretty sure that this has long been fixed. Please feel free to reopen if these URLs are still crashing for you on any platform (here they're not).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Still crashes for on Mac using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4pre) Gecko/20100809 Minefield/4.0b4pre with WebGl enabled when I load the site in the URL.

http://crash-stats.mozilla.com/report/index/bp-c7758b4e-68f7-4ce6-87a9-98ab92100803
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Well I guess my crash now seems to be a dupe of Bug 585502?
Yep, the new crash trace in comment 5 is a dupe of bug 585502, and is unrelated to the original crashed reported here. Also, since it happens much later in the WebGL execution flow, the fact that you're getting this new crash shows that the old crash is no longer happening.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Crash Signature: [@ @0x0 | mozilla::WebGLContext::SetDimensions(int, int) ]
Issue is resolved - clearing old keywords - qa-wanted clean-up
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.