CheckFinalReturn is not exception-savvy

VERIFIED DUPLICATE of bug 49233

Status

()

P3
normal
VERIFIED DUPLICATE of bug 49233
18 years ago
17 years ago

People

(Reporter: shaver, Assigned: shaver)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

<brendan> (ahem; exception-adding spidermonkeys forgot about my CheckFinalReturn
functions!)

So I (we?) did.  I shall repair it with the following one-liner, if the JS gods
so permit:

Index: jsparse.c
===================================================================
RCS file: /cvsroot/mozilla/js/src/jsparse.c,v
retrieving revision 3.44
diff -u -r3.44 jsparse.c
--- jsparse.c	2000/09/12 19:42:01	3.44
+++ jsparse.c	2000/10/15 15:46:32
@@ -315,6 +315,7 @@
       case TOK_WITH:
         return CheckFinalReturn(pn->pn_right);
       case TOK_RETURN:
+      case TOK_THROW:
         return JS_TRUE;
       default:
         return JS_FALSE;
Status: NEW → ASSIGNED
Blah.  49233 has discussion of this (I missed it in my search for an existing
bug, because its summary gives no hint), and a better solution.

It feels wrong to dup this to a bug about eval, but I'll live.


*** This bug has been marked as a duplicate of 49233 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dupe. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.