If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bcJavaStubsAndProxies not thread-safe

VERIFIED DUPLICATE of bug 78281

Status

Core Graveyard
Java to XPCOM Bridge
P3
normal
VERIFIED DUPLICATE of bug 78281
17 years ago
3 years ago

People

(Reporter: Jon Smirl, Assigned: Igor Kushnirskiy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
**[c++]hasRetval: 0
--nsresult bcJavaMarshalToolkit::UnMarshal
--[c++] bcJavaMarshalToolkit::UnMarshalElement we have an interface
0 oid
--[c++] bcJavaStubsAndProxies::GetInterface
--[java] ProxyFactory.getInterface org.mozilla.xpcom.IID@47267425-667b-11d4-b7dc
-00a0cc3e7072
--[java]org.mozilla.xpcom.Utilities.callMethodByIndex 1 7
--[java]callMethodByIndex args[0] = null
--[java] org.mozilla.xpcom.Utilities.callMethodByIndex method null
--[java] Utilities.callMethodByIndex method finishednull
--[c++] bcXPCOMProxy::Release 0
--bcJavaComponentFactory::CreateInstance
###!!! ASSERTION: bcJavaStubsAndProxies not thread-safe: 'owningThread == NS_Cur
rentThread()', file d:\cvs\mozilla\xpcom\base\nsDebug.cpp, line 490

Comment 1

17 years ago
setting Jon Smirl's bugs to New
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
hopefully george will try to find a new owner for this bug
Assignee: akhil.arora → drapeau

Comment 3

17 years ago
Ashu is taking ownership of JavaDOM bugs.  Re-assigning to him.
Assignee: drapeau → ashuk

Comment 4

17 years ago
Changing QA contact.
Looks like this is BlackConnect(Java-to-XPCOM Bridge) bug. 
Igor, could you please look at it and change category ?  
QA Contact: rajendra.pallath → avm

Comment 5

17 years ago
Hello Igor,
This Bug is in BlackConnect and relates to thread-safety. I believe that you
have this feature working by now, and so this bug might just need to be closed.
Anyways, I am assigning it to you since it belongs in the BlackConnect module.
thnx. _Ashu
Assignee: ashuk → idk
Component: Java APIs for DOM → Java to XPCOM Bridge
(Assignee)

Comment 6

17 years ago
Closing as dup

*** This bug has been marked as a duplicate of 78281 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
Verified DUP
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.