Cookies expire until the expiration time comes

RESOLVED DUPLICATE of bug 541356

Status

()

RESOLVED DUPLICATE of bug 541356
9 years ago
9 years ago

People

(Reporter: virus_found, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100520 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100520 Minefield/3.7a5pre

Some cookies expire right after the browser's closure, despite their expire date being two months later.

Reproducible: Always

Steps to Reproduce:
1. Clear all livejournal.com cookies (not necessary, but needed for "clear" reproduce).
2. Visit http://www.livejournal.com
3. Enter your login and password, tick "Remember", log in.
4. Open the cookies manager, search for "journa", see quite a bunch of cookies?
5. Let's remember one of those, say, titled "ljloggedin", expiration time is "Wed 21 Jul 2010 02:42:33 AM MSD" (in two months).
6. Close the tab, close the browser.
7. Open cookies.sqlite in the profile dir with any text editor, make sure, it has only one instance of "journa".
8. Open the browser, make sure, the cookies manager has only one instance of "journa" (titled "ljuniq").
Actual Results:  
"ljloggedin" and other livejournal cookies expire right after the browser's closure.

Expected Results:  
"ljloggedin" and other livejournal cookies expire in two months, not after the browser's closure.

Unfortunately, you have to have an account there already, or to register one. Tested with new profile. The settings for cookies are "keep until they expire" (by default).
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Version: Trunk → unspecified
Duplicate of bug: 541356
You need to log in before you can comment on or make changes to this bug.