clobber_seamonkey seems to take out nspr header files

RESOLVED WONTFIX

Status

P4
normal
RESOLVED WONTFIX
18 years ago
14 years ago

People

(Reporter: simon.lucy, Assigned: leaf)

Tracking

Trunk
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Today I ran the build with clobber_seamonkey and then built again with 
build_seamonkey and it barfed on prtypes.h not existing which is created as 
part of NSPR.

I don't really want to test it again :-)

Comment 1

18 years ago
The problem is that a clobber_seamonkey removes the dist directory.  Recommended
fix, remove the _psm & _seamonkey build & clobber rules and have users just use
build_all & clobber_all.  Leaf, any thoughts?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 2

18 years ago
It should be feasible to have builds which are independant though

Comment 3

18 years ago
Please define "builds which are independent".  I don't see how you can build
seamonkey "independent" of nspr because seamonkey *requires* nspr.  Because nspr
places its headers & other generated files in dist/ just like seamonkey, they
get blown away when any of the clobber_<blah> rules are invoked.  
(Reporter)

Comment 4

18 years ago
SeaMonkey is dependant on NSPR for sure, but NSPR isn't dependant on SeaMonkey 
so blowing away the distribution of SeaMonkey shouldn't blow away NSPR, or the 
NSPR headers that are needed in order to build SeaMonkey.
(Assignee)

Comment 5

18 years ago
*sigh* If we want to have builds be ``independent'' they need to have distinct
dist directories, so you can whack each dist independently.

A workaround is to force the rebuilding of components once dist has been
removed, and since they only thing required is re-exporting things, it shouldn't
be too onerous.

Comment 6

18 years ago
Reassigning to leaf.
Assignee: cls → leaf
Status: ASSIGNED → NEW
Priority: P3 → --

Comment 7

18 years ago
is this bug still valid with all the recent changes?
Priority: -- → P4
Target Milestone: --- → mozilla1.2

Comment 8

18 years ago
Well, as much as it ever was valid.  Using the toplevel client.mak is for
building mozilla (and a couple of mozilla submodules).  NSPR is independent and
can be built independently but not using client.mak.  I don't think we should
have to worry about keeping NSPR *that* independent when building from mozilla's
client.mak.  

Comment 9

17 years ago
bug cleanup - all leaf's bugzilla bugs should be assigned to leaf@mozilla.org
(not leaf@netscape.com), now and any future bugs created.

this should be a one time change, apologies for the spam.
Assignee: leaf → leaf

Comment 10

16 years ago
2 years idle.  should probably be wontfix, but for now punting to Future.
Target Milestone: mozilla1.2alpha → Future

Comment 11

15 years ago
The nmake makefiles are no longer used.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.