Stalls at splash screen after 4.75 profile migration

VERIFIED DUPLICATE of bug 46882

Status

Core Graveyard
Profile: Migration
P3
normal
VERIFIED DUPLICATE of bug 46882
18 years ago
2 years ago

People

(Reporter: eugfi, Assigned: dbragg)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001015
BuildID:    2000101508

After the install process is complete it asks to migrate your profile. Migrate
your profile then the splashscreen appears and nothing happens. In the task list
[alt+ctl+del] you see "Mozilla (not responding)"

Reproducible: Always
Steps to Reproduce:
1. Delete all traces of Mozilla from your system.
2. Use win32 Installer build to install
3. Convert your NC 4.75 profile

Actual Results:  1. Profile is converted/migrated.
2. Splash screen appears and there is some hard drive activity
3. Hard drive stops
4. Mozilla stops responding

Creating a new profile will make Mozilla work properly

Expected Results:  Splash screen goes away and Mozilla starts.

From the console

"...start with profile: Maxwell
ProfileManager : StartApprunner
profileName passed in: Maxwell"

The process dies at profileName passed in: Maxwell
(Assignee)

Comment 1

18 years ago
The debugging string "profileName passed in:" is in nsProfile.cpp.  The
perceived crash is in the Profile Manager code.  Although I think the problem
lies beyond that point, possibly even in the browser code itself.

(Assignee)

Comment 2

18 years ago
Adding Racham to the cc list.

Comment 3

18 years ago
Works for me on Linux 2000201009. It migrated all three of my Netscape profiles
rather well. Migration has not been a problem on my platform in a long time. If
another linux guy can confirm this then maybe we can narrow it down to platform.

Comment 4

18 years ago
Works for doron too.. :) marking WFM .....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

18 years ago
Win32 Installer build ID #2000102704 on Windows98:

Problem still occurs. The bookmark file that was migrated from 4.75 to Mozilla
was 304KB. When I replaced this bookmark file with one that was 16 KB I could
start Mozilla. It appears to me that the size of the bookmark file is part of
the problem.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

18 years ago
this is bug 46882

*** This bug has been marked as a duplicate of 46882 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
vfy dupe
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.