generated addon non-functional after restart on Firefox trunk (Minefield)

RESOLVED DUPLICATE of bug 567319

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 567319
8 years ago
8 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
while testing some other bugs, i noticed that my addon's main.js::exports.main() wasn't being executed on subsequent startups after install.

STR:

1. install your addon
2. restart

expected: addon still is functional after restart

actual: main() doesn't seem to be executed

this is on trunk. haven't tested 3.6.
(Reporter)

Comment 1

8 years ago
if y'all can confirm this, it's a blocker.

Comment 2

8 years ago
This is bug 567319, which Dave and I found while looking at bug 567293.  Dave posted the patch there before he left for a trip on Thursday night.  I couldn't get it to work, and we couldn't figure out why.  He emailed me today to say that he'd posted the wrong patch and that he wouldn't be able to post the right one until Sunday or Monday, since his connection is intermittent.  (Not sure why he didn't post that info to the bug.)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 567319

Updated

8 years ago
OS: Linux → All
Hardware: x86 → All
Summary: generated addon non-functional after restart → generated addon non-functional after restart on Firefox trunk (Minefield)
(Reporter)

Comment 3

8 years ago
hrm. i don't like the idea of releasing 0.4 while that bug is still present on trunk. it looks like it'll get fixed in time, so we might be ok. we should consider holding the release though, if it doesn't.
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.