Can't input multiple addresses on single TO: line anymore after "upgrading" from v2 to v3

RESOLVED DUPLICATE of bug 528503

Status

Thunderbird
Address Book
--
major
RESOLVED DUPLICATE of bug 528503
8 years ago
8 years ago

People

(Reporter: scott, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Ubuntu 10.04

In Thunderbird 2 I was able to enter multiple addresses on the "To:" line, separated by commas.

In Thunderbird 3 this no longer works.

eg:

In TB2 I could enter:

To: dad, mom, tom, dick, harry

When I hit the Tab key, the cursor would move down to the message body pane, and all of the addresses in the To: field would be split onto separate lines and converted to their appropriate entries in the Address Book, so it would look like:

To: "dad" <dads.address@dads.domain.com>
To: "mom" <moms.address@moms.domain.com>
To: "Tom Smith" <tom@this.domain.com>
To: "Dick van Head" <****@that.domain.com>
To: "Harry Armepitte" <harry@the.other.domain.com>

Now, in Version 3.0.4, if I enter the same thing on the "To:" line, when I hit tab the cursor still moves to the message body pane, and the addresses still split onto multiple "To:" lines, but the addresses don't seem to get looked up in the Address Book anymore: the names on the multiple lines don't get converted, it just looks like:

To: dad
To: mom
To: tom
To: dick
To: harry

...and all the names are colored red. 

If I try to send the e-mail like that it has errors.

So if I want to send to multiple recipients, I have to type one recip into the To: field, hit tab for it to do the Address Book lookup and convert the nickname into a proper address, then manually click the next "To:" field.

This definitely doesn't seem like an "upgrade feature" so I assume it's a bug.

Thanks,
Scott

Reproducible: Always

Steps to Reproduce:
1. Compose a new e-mail
2. Enter multiple recipients as nicknames or partial addresses (this was supported in TB2)
3. Hit tab
4. Shake fist in frustration
Actual Results:  
I filed a bug report.

Expected Results:  
Converted the nicknames and partial addresses into full addresses
Whiteboard: dupeme

Comment 1

8 years ago
Known regression, unfortunately not fixed in the upcoming 3.1 yet either...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 528503
You need to log in before you can comment on or make changes to this bug.