[gcc 4.5] Build process is busted while processing src/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc

RESOLVED DUPLICATE of bug 569836

Status

()

Toolkit
Crash Reporting
--
critical
RESOLVED DUPLICATE of bug 569836
8 years ago
8 years ago

People

(Reporter: Frederic Bezies, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a5pre) Gecko/20100522 Firefox/3.7a5pre
Build Identifier: 

I cannot get minefield to be build for a few days. Every time, process is killed while processing src/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc

It seems to be related to :


/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc:132:20: erreur: ‘fstat’ was not declared in this scope

Reproducible: Always

Steps to Reproduce:
1.Grab last sources
2.build them
3.wait
Actual Results:  
Crash while processing src/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc

Expected Results:  
Keep on building until it finished itself !

I'm using archlinux testing.

Gcc :

[fred@fredo-arch src]$ gcc -v
Utilisation des specs internes.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-unknown-linux-gnu/4.5.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configuré avec: ../configure --prefix=/usr --enable-languages=c,c++,fortran,objc,obj-c++,ada --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-gnu-unique-object --enable-lto --enable-plugin --disable-multilib --disable-libstdcxx-pch --with-system-zlib --with-ppl --with-cloog --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info
Modèle de thread: posix
gcc version 4.5.0 20100520 (prerelease) (GCC) 

Here is the .mozconfig :

#
# See http://www.mozilla.org/build/ for build instructions.
#

export AUTOCONF=autoconf-2.13

. $topsrcdir/browser/config/mozconfig

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../objdir-fx
#mk_add_options MOZ_MAKE_FLAGS=-j4

# Options for ‘configure’ (same as command-line options).
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --disable-tests
#ac_add_options --disable-crash-reporter

And the crash log :

file_id.cc
In file included from /home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc:37:0:
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2192:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2192:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2204:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2204:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2205:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2205:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2206:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2206:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2207:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2207:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2208:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2208:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2216:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2216:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2265:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2265:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2279:1: attention : ISO C99 requiert que tous les arguments soient utilisés
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/../../common/linux/linux_syscall_support.h:2279:1: attention : invoking macro LSS_BODY argument 3: empty macro arguments are undefined in ISO C90 and ISO C++98
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc: In member function ‘bool google_breakpad::FileID::ElfFileIdentifier(uint8_t*)’:
/home/fred/logs/fox/src/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc:132:20: erreur: ‘fstat’ was not declared in this scope
make[6]: *** [host_file_id.o] Erreur 1
make[5]: *** [libs] Erreur 2
make[4]: *** [crashreporter_libs] Erreur 2
make[3]: *** [libs_tier_platform] Erreur 2
make[2]: *** [tier_platform] Erreur 2
make[1]: *** [default] Erreur 2
make: *** [build] Erreur 2
Duping to bug 569836 because it has a patch.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569836
You need to log in before you can comment on or make changes to this bug.