If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Keyboard shortcuts without modifier should not be active

RESOLVED WONTFIX

Status

Core Graveyard
Skinability
P3
normal
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: madsci, Unassigned)

Tracking

({helpwanted})

Trunk
Future
x86
Linux
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.14 i686)
BuildID:    2000101509, M18

some keyboard shortcuts have no qualifier key. As a result, shortcuts are
activated when keys pressed to enter into address bar, forms, etc. Is this a bug
or a problem with my setup???

Reproducible: Always
Steps to Reproduce:
1. Press a key that has a shortcut without a qualifier, even if focus is in
form, address bar, etc.
2.
3.

Actual Results:  Shortcut is activated (windows pop open, etc). This makes
Mozilla unusable because I cannot type anything into the address bar, and form,
etc.                 

Expected Results:

Comment 1

17 years ago
changing component
Assignee: asa → don
Component: Browser-General → Keyboard Navigation
QA Contact: doronr → sairuh
madsci, could you pls give me a specific example of this problem? thx!

Comment 3

17 years ago
madsci: are you sure that you have the build ID correct? This was a known and
fixed bug about a month ago, and I can't force it to come back in more recent
builds. Please download a more recent build from
http://ftp.mozilla.org/pub/mozilla/nightly/latest/, delete your .mozilla, and
try it again. Thanks!
pasting email from the reporter (thx, Doug!):

This happened with:

Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; m18) Gecko/20001010

and with the nightly build I downloaded on
the night that I first filed the report.

I do have a bit more info on what happened:

I downloaded some themes to try
(View->Apply Theme->Get New Themes)
One of the themes appears to have changed 
the keyboard shortcuts, so that some of them
did not have any qualifiers (ie: Open = O
instead of Open = Ctrl+O) . This resulted
in the keyboard shortcut being activated
the key was pressed for an unqualified KB
shortcut, regardless of where I was typing
(address bar, form on web, etc).

Changing back to one of the default themes
did not restore the KB shortcuts. To fix
the probme, I wound up removing Mozilla
from the system, and re-installing it again.

It would be nice if Mozilla disabled keyboard
shortcuts that are not qualified with either
the CTRL or ALT keys to prevent this type of
problem in the future with poorly designed
themes. Also, the default themes should restore
the keyboard shortcuts as anything else that a
theme can change, to allow easier recovery from
problems that may arise from other themes.
 
Doug McLean (Mad Scientist)
--------------------------------------------------------
fascinating... skinability issue (theme switching)?
Assignee: don → ben
Component: Keyboard Navigation → Skinability
QA Contact: sairuh → blakeross

Comment 6

17 years ago
setting bug status to New.  Reporter, what theme was this? (please reply to the
bug itself. there is a link on this email notice you are reading right now)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

17 years ago
Sorry, I don't know which skin it was that started the problem, I installed and
tried several at once. Switching to the default skin again did not correct the
problem because the default skin did not correct the keyboard shortcuts.

Comment 8

17 years ago
Not a blocker.
Severity: blocker → normal

Comment 9

17 years ago
Pretriage of skinnability bugs, marking nsbeta1-, not going to get time to fix 
this for beta1
Keywords: nsbeta1-

Comment 10

17 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future
Mass move skinability bugs to nobody@mozilla.org, helpwanted. 
Assignee: ben → nobody
Keywords: helpwanted

Comment 12

15 years ago
As far as I know, themes cannot change keyboard binding. Language
packs, however, can change keybaord binding.

We need a test case. Reporter, please give us the url of the
theme so we can triage this bug.
URL: any
Summary: some keyboard shortcuts have no qualifier key. As a result, shortcuts are activated when keys pressed to enter into address bar, forms, etc. → Keyboard shortcuts without modifier should not be active

Updated

15 years ago
Depends on: 91094

Comment 13

15 years ago
bug 70630 (ASSIGNED) is an opposite of this bug

Comment 14

13 years ago
*** Bug 91094 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.