Closed Bug 567877 Opened 10 years ago Closed 10 years ago

[OOPP] After watching the video, crash on exit [@ mozilla::plugins::PluginInstanceParent::NPP_URLNotify(char const*, short, void*) ]

Categories

(Core :: Plug-ins, defect, critical)

1.9.2 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 558130

People

(Reporter: vadimrapp, Unassigned)

References

()

Details

(Keywords: crash, qawanted)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100513 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100513 Firefox/3.6.4

after watching the video at http://eclipptv.com , firefox crashes on closing the window.

Reproducible: Always

Steps to Reproduce:
1. navigate to http://eclipptv.com/viewVideo.php?video_id=12001
2. watch the video (not necessarily to the end)
3. close Firefox. It will crash.
Actual Results:  
crash info was submitted - 2cf6550f-f0c4-4686-8c7b-ca98b2100524
This one was Firefox in safe mode

bp-349aa57e-4ed9-44e0-a871-8090f2100524
this one was in normal mode
0  	 	@0x24220202  	
1 	xul.dll 	mozilla::plugins::PluginInstanceParent::NPP_URLNotify 	dom/plugins/PluginInstanceParent.cpp:757
2 	xul.dll 	mozilla::plugins::PluginModuleParent::NPP_URLNotify 	dom/plugins/PluginModuleParent.cpp:495
3 		@0x2f8bc0b 	
4 	xul.dll 	nsNPAPIPluginStreamListener::CleanUpStream 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:301
5 	xul.dll 	nsNPAPIPluginInstance::Stop 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:1177
6 	xul.dll 	DoStopPlugin 	layout/generic/nsObjectFrame.cpp:2283
7 	xul.dll 	nsStopPluginRunnable::Run 	layout/generic/nsObjectFrame.cpp:2333
8 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
9 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:118
10 	xul.dll 	xul.dll@0x9be307 	
11 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:199
Severity: normal → critical
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core
QA Contact: general → plugins
Summary: After watching the video, crash on exit → [OOPP] After watching the video, crash on exit [@ mozilla::plugins::PluginInstanceParent::NPP_URLNotify(char const*, short, void*) ]
Version: unspecified → 1.9.2 Branch
Vadim, could you try the latest candidate 3.6.4build5 and see if you can still see this problem? I haven't been able to reproduce it on the latest nightly nor the latest candidate build for 3.6.4.

The signature looks like the one in bug 558130.
Keywords: qawanted
tried 3.6.4 build5 - did not crash.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 558130
Crash Signature: [@ mozilla::plugins::PluginInstanceParent::NPP_URLNotify(char const*, short, void*) ]
You need to log in before you can comment on or make changes to this bug.