Closed Bug 567931 Opened 14 years ago Closed 14 years ago

toolkit/components/alerts/test/test_alerts.html takes 5 minutes to complete (and fails)

Categories

(Firefox :: Shell Integration, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 3.7a5

People

(Reporter: MatsPalmgren_bugz, Assigned: MatsPalmgren_bugz)

References

Details

Attachments

(1 file)

toolkit/components/alerts/test/test_alerts.html takes 5 minutes to complete (and fails)

STEPS TO REPRODUCE
1. run this test in debug build on Kubuntu 9.10

ACTUAL RESULTS
a. the test fails (even though I _do_ see the system alert box)
b. the test hangs for 5 minutes before continuing to the next test
Attached patch Patch rev. 1Splinter Review
Wait at most 15 seconds for the notification, then fail the test.

Should I file a separate bug on the missing notification or is this
a known problem for some systems?
Assignee: nobody → matspal
Attachment #447250 - Flags: review?(ventnor.bugzilla)
Attachment #447250 - Flags: review?(ventnor.bugzilla)
The patch worked fine on TryServer so I pushed it:
http://hg.mozilla.org/mozilla-central/rev/bca9ed2dc6cf
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Target Milestone: --- → Firefox 3.7a5
Version: unspecified → Trunk
Depends on: 611540
(In reply to comment #1)
> Should I file a separate bug on the missing notification or is this
> a known problem for some systems?

No answer in 5.5 months:
if the test still fails, please file a bug ;-)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: