[@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent(mozilla::plugins::NPRemoteEvent const&, short*)] Flickr file-upload

RESOLVED DUPLICATE of bug 567645

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 567645
8 years ago
8 years ago

People

(Reporter: graydon, Unassigned)

Tracking

({hang})

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Win7 x64, 3.7a5pre, nightly.
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100523 Minefield/3.7a5pre (.NET CLR 3.5.30729)

STR:
1. ensure OOPP is enabled
2. log in to a flickr account
3. You -> Upload photos and videos -> Choose photos and videos

Result: Flash subprocess crashes, browser asks if I want to restart it.
Expected: Flash normally spawns a file-picker.

100% reproducible for a few days now. Worked as recently as a week ago. Disabling OOPP gets around this, so I'm pretty sure it's ours.
(Reporter)

Updated

8 years ago
Hardware: x86 → x86_64
Version: unspecified → Trunk

Comment 1

8 years ago
Maybe Bug 567647
(Reporter)

Comment 2

8 years ago
Possibly. Forgot to add flash details:

File: NPSWF32.dll
Version: 10.0.45.2
Shockwave Flash 10.0 r45

(updated today to check if it was culprit)
crash ID ?
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> crash ID ?

Not sure I know what that means. You want a socorro reference? This isn't crashing the browser.
(Reporter)

Comment 5

8 years ago
Oh, I see. Filed. There are two in about:crashes that look like they were filed at the same event. Not sure which you want:

http://crash-stats.mozilla.com/report/index/bp-82226bc0-ca74-4583-af0c-451ad2100524
http://crash-stats.mozilla.com/report/index/bp-58396eda-ba7c-46c0-b5a9-221362100524

Comment 6

8 years ago
graydon, fwiw, if you look at the top right of these reports you'll see "Hang" in red.

Signature	hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent(mozilla::plugins::NPRemoteEvent const&, short*)
UUID	82226bc0-ca74-4583-af0c-451ad2100524
Time 	2010-05-24 20:33:55.401324
Uptime	32
Product	Firefox
Version	3.7a5pre
Build ID	20100523040016
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 11
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x72d8310f
User Comments	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
6 	xul.dll 	CrashReporter::CreatePairedMinidumps 	toolkit/crashreporter/nsExceptionHandler.cpp:1729
7 	xul.dll 	mozilla::plugins::PluginModuleParent::ShouldContinueFromReplyTimeout 	dom/plugins/PluginModuleParent.cpp:227
8 	xul.dll 	mozilla::ipc::SyncChannel::ShouldContinueFromTimeout 	ipc/glue/SyncChannel.cpp:261
9 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:210
10 	xul.dll 	mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:339
11 	xul.dll 	mozilla::plugins::PluginInstanceParent::NPP_HandleEvent 	dom/plugins/PluginInstanceParent.cpp:805
12 	xul.dll 	mozilla::plugins::PluginModuleParent::NPP_HandleEvent 	dom/plugins/PluginModuleParent.cpp:485
13 	xul.dll 	nsNPAPIPluginInstance::HandleEvent 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:1378
14 	xul.dll 	nsPluginInstanceOwner::ProcessEvent 	layout/generic/nsObjectFrame.cpp:4680
15 	xul.dll 	nsObjectFrame::HandleEvent 	layout/generic/nsObjectFrame.cpp:1947
16 	xul.dll 	nsPresShellEventCB::HandleEvent 	layout/base/nsPresShell.cpp:1336
17 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:386
18 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:628
19 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6523
20 	xul.dll 	PresShell::HandleEvent 	
21 	xul.dll 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1073
22 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1052
23 	xul.dll 	HandleEvent 	view/src/nsView.cpp:160
24 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3188
25 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3211
26 	xul.dll 	nsWindow::DispatchPluginEvent 	widget/src/windows/nsWindow.cpp:3381
27 	xul.dll 	nsWindow::ProcessMessageForPlugin 	widget/src/windows/nsWindow.cpp:4004
28 	xul.dll 	nsWindow::ProcessMessage 	
29 	xul.dll 	nsWindow::WindowProc 	widget/src/windows/nsWindow.cpp:3923
30 	user32.dll 	InternalCallWinProc 	
31 	user32.dll 	UserCallWinProcCheckWow 	
32 	user32.dll 	SendMessageWorker 	
33 	user32.dll 	SendMessageW 	
34 	imm32.dll 	imm32.dll@0x122b2 	
35 	imm32.dll 	imm32.dll@0x137cb 	
36 	xul.dll 	nsWindow::SetIMEEnabled 	widget/src/windows

Filename 	Version 	Debug Identifier 	Debug Filename
imm32.dll 	6.1.7600.16385 	68C7808EB69642399E0B930F19CCEFBD2 	

Signature	hang | ntdll.dll@0x200fd
UUID	58396eda-ba7c-46c0-b5a9-221362100524
Process Type	plugin Version: Filename: NPSWF32.dll
Time 	2010-05-24 20:33:54.499173
Uptime	12
Product	Firefox
Version	3.7a5pre
Build ID	20100523040016
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 11
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x77ba00fd
User Comments	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	ntdll.dll@0x200fd 	
1 	kernel32.dll 	kernel32.dll@0x1162c 	
2 	kernel32.dll 	kernel32.dll@0x11920 	
3 	kernel32.dll 	kernel32.dll@0x39b0c 	
4 	kernel32.dll 	kernel32.dll@0x39ba9 	
5 	kernel32.dll 	kernel32.dll@0x398d7 	
6 	kernel32.dll 	kernel32.dll@0x39854 	
7 	ntdll.dll 	ntdll.dll@0x70726 	
8 	ntdll.dll 	ntdll.dll@0x39d44 	

Thread 6
Frame 	Module 	Signature [Expand] 	Source
0 	user32.dll 	NtUserGetMessage 	
1 	user32.dll 	NtUserGetMessage 	
2 	user32.dll 	GetMessageA 	
3 	xul.dll 	WalkStackThread 	xpcom/base/nsStackWalk.cpp:636
4 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:348
5 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:326
6 	kernel32.dll 	kernel32.dll@0x13676 	
7 	ntdll.dll 	ntdll.dll@0x39d71 	
8 	ntdll.dll 	ntdll.dll@0x39d44 	

This thread is odd.

Filename 	Version 	Debug Identifier 	Debug Filename
NPSWF32.dll 	10.0.45.2 	EF4B0B547B3349C898B243CC64A91FF61 	NPSWF32.pdb
Summary: Flickr file-upload crashes OOPP only → [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_HandleEvent(mozilla::plugins::NPRemoteEvent const&, short*)] Flickr file-upload

Updated

8 years ago
Keywords: hang
(Reporter)

Comment 7

8 years ago
Yeah, I noticed the "hang" bit but am unsure what that word means in this context. Also the EXCEPTION_BREAKPOINT bit. I don't know how our shiny new IPC layer works but this sounds more like a detected-and-trapped communications fault than a memory error.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 567645

Comment 9

8 years ago
graydon: yep, exception_breakpoint means roughly what it says, there's an instruction which acts as a breakpoint, it's handled by the os as an exception, if there's a debugger listening, the debugger typically catches it. unlike most exceptions, breakpoints aren't inherently fatal. in our case, crashreporter is listening, and it sends the report, which enables us to detect things like this (typically potential deadlock or other constraint violations).
You need to log in before you can comment on or make changes to this bug.