Dragging bookmarks on personal toolbar deletes them

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
major
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Millennium, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001015
BuildID:    2000101520

When dragging icons on the Location Toolbar, they are deleted instead of moved.
They do not appear in the Location Toolbar, the Bookmarks Panel, or the
Bookmarks Menu.

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla.
2. If there are no icons in the Location Toolbar, create some.
3. Drag the bookmarks around on the toolbar (do not drag them off of it).

Actual Results:  The icon being dragged disappears and is deleted from the
database. The remaining icons rearrange themselves to compensate for the lost icon.

Expected Results:  The icon moves to the position where it was dropped, and the
bookmarks rearrange themselves to compensate.

Comment 1

18 years ago
Assuming you mean the personal toolbar, that feature is not in the product.  Did
you enable the debug pref for dragging personal toolbar items?

Comment 2

18 years ago
->future, reopen if there is a crash scenario in N6 which doesn't require
changing debug prefs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future
(Reporter)

Comment 3

18 years ago
Clarifying: I did mean the Personal Toolbar. Sorry about that. And yes, the
debug pref for dragging personal toolbar items was enabled.

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Blocks: 46456

Updated

18 years ago
Summary: Dragging bookmarks on location bar deletes them → Dragging bookmarks on personal toolbar deletes them

Comment 4

18 years ago
Clearing future milestone: this blocks bug 46456 (enable pref for personal 
toolbar drag-and-drop by default), which is targeted to mozilla 0.9.
Target Milestone: Future → ---

Comment 5

18 years ago
->pink
Assignee: trudelle → pinkerton
Status: ASSIGNED → NEW
ben did all this.
Assignee: pinkerton → ben

Comment 7

18 years ago
*** Bug 59612 has been marked as a duplicate of this bug. ***

Updated

18 years ago
No longer blocks: 46456
Keywords: nsbeta1

Comment 8

18 years ago
I can't replicate this bug (with or without the debug preference checked) on
Mozilla .8 (2001021508) on Windows 98... anyone confirm as WORKSFORME?

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
Worksforme with 022705 mozilla win32 build on NT Drag and Drop doesn't delete
any items)
You need to log in before you can comment on or make changes to this bug.