cssp offsetWidth shortened to smaller window width

RESOLVED DUPLICATE of bug 65548

Status

()

Core
DOM
P5
normal
RESOLVED DUPLICATE of bug 65548
18 years ago
5 years ago

People

(Reporter: Martin Jacobs, Assigned: jst)

Tracking

({dom1, testcase})

Trunk
Future
dom1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m18) Gecko/20001015
BuildID:    2000101520

When opening a small window with larger content, content offsetWidth is
shortened to window width.  Window can't be resized according to its content.
offsetHeight still gives correct value.
An M18 bug.

Reproducible: Always
Steps to Reproduce:
1/open a smaller window (100x100)
2/write larger content into it, enclosed in an absolute positioned div element
3/close document
4/get div offsetWidth and offsetHeight

Actual Results:  offsetWidth is shortened to window width,
offsetHeight works fine

Expected Results:  offsetWidth should give full width of its element, including
overflow.

this regression happens since M18 2000-10-12;
NSpr3 and M17 where OK.
see attached file.
(Reporter)

Comment 1

18 years ago
Created attachment 17241 [details]
try to resize small window according to its content width/height
(Assignee)

Comment 2

18 years ago
Unfortunately it's too late to fix this right now, it'll haveto wait for hte
next release. Marking Future.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows 95 → All
Hardware: PC → All
Summary: cssp offsetWidth shortened to smaller window width → cssp offsetWidth shortened to smaller window width
Target Milestone: --- → Future
(Reporter)

Comment 3

18 years ago
Till then, workaround used : 
blur + maximize + get offsetWidth + resize + focus 
Keywords: dom1
Component: DOM Level 1 → DOM HTML

Comment 4

17 years ago
QA contact Update
QA Contact: janc → desale

Comment 5

17 years ago
Updating QA contact to Shivakiran Tummala.
QA Contact: desale → stummala

Comment 6

16 years ago
Priority P5, severity normal, -> DOM Mozilla Extensions (offset* issue)
Severity: major → normal
Component: DOM HTML → DOM Mozilla Extensions
Keywords: testcase
Priority: P3 → P5

Comment 7

16 years ago
still an issue?

Comment 8

16 years ago
remove self

Comment 9

16 years ago
So I have this issue with a div, that is positioned so that half of it is
outside the viewable area (so half of it is to the right, outside the viewport)
offsetWidth returns half the size (ie the area that is viewable).

I assume this is the same issue as this bug, right?
(Reporter)

Comment 10

16 years ago
Probably the same issue.  
Marking dup of bug with better analysis.

*** This bug has been marked as a duplicate of 65548 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.