(py2.5) ERROR: test_generate_static_docs_does_not_smoke (cuddlefish.tests.test_server.ServerTests)

RESOLVED FIXED

Status

Add-on SDK
General
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: adw, Assigned: warner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

From the mailing list [1], and I see it too.  Happens with cfx testall, but cfx testcfx specifically seems to be the problem.

[1] http://groups.google.com/group/mozilla-labs-jetpack/msg/7326794376a9aa9e

(jetpack-sdk)00:06:26 ~/jetpack-sdk$ cfx -b /Applications/Minefield.app/Contents/MacOS/firefox-bin testcfx
.......................E.......................
======================================================================
ERROR: test_generate_static_docs_does_not_smoke (cuddlefish.tests.test_server.ServerTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/adw/jetpack-sdk/python-lib/cuddlefish/tests/test_server.py", line 12, in test_generate_static_docs_does_not_smoke
    server.generate_static_docs(env_root, tgz_filename=filename)
  File "/Users/adw/jetpack-sdk/python-lib/cuddlefish/server.py", line 378, in generate_static_docs
    shutil.copytree(server.root, staging_dir, ignore=_tempfiles)
TypeError: copytree() got an unexpected keyword argument 'ignore'

----------------------------------------------------------------------
Ran 47 tests in 3.474s

FAILED (errors=1)

Comment 1

8 years ago
I'm using Python 2.6 and therefore cannot see this.
"ignore" seems to have been introduced in Python 2.6:

http://docs.python.org/library/shutil.html#shutil.copytree

Comment 2

8 years ago
Regression of http://hg.mozilla.org/labs/jetpack-sdk/rev/9ac87686d6e9

As a simple fix we can either drop python 2.5 support or don't ignore files that end with tildes(~) if python < 2.6.

Comment 3

8 years ago
I strongly prefer not dropping support for Python 2.5, since it's likely that lots of developers may have 2.5 but not 2.6 on their system. For example, OS X 10.5 comes with python 2.5, so dropping support for 2.5 would require folks on that OS to either upgrade to Snow Leopard or get a new version of Python, both of which are a big hassle.

I'm ok with the latter simple fix, or perhaps "hacking" support for the 'ignore' keyword into shutil.copytree if we're not on 2.6 (dunno how hard that'd be though).
(Assignee)

Updated

8 years ago
Assignee: nobody → warner-bugzilla
Status: NEW → ASSIGNED
Summary: ERROR: test_generate_static_docs_does_not_smoke (cuddlefish.tests.test_server.ServerTests) → (py2.5) ERROR: test_generate_static_docs_does_not_smoke (cuddlefish.tests.test_server.ServerTests)
(Assignee)

Comment 4

8 years ago
Created attachment 448794 [details] [diff] [review]
don't use ignore=

This patch copies everything, and then deletes the tempfiles afterwards. It works on my py2.5 linux box.
Attachment #448794 - Flags: review?(avarma)

Comment 5

8 years ago
Comment on attachment 448794 [details] [diff] [review]
don't use ignore=

Looks great, thanks!
Attachment #448794 - Flags: review?(avarma) → review+
(Assignee)

Comment 6

8 years ago
Applied, in http://hg.mozilla.org/labs/jetpack-sdk/rev/7d6f50a0fca1
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.