ServerError: error 10 from memcached_add: SERVER ERROR

VERIFIED FIXED in 5.11

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: Pratibha, Assigned: jbalogh)

Tracking

unspecified
5.11

Details

(URL)

(Reporter)

Description

8 years ago
Steps to reproduce:

- Navigate to the add-on details page:
URL: https://preview.addons.mozilla.org/en-US/firefox/addon/161727/

Expected Result: add-on details page loads

Actual Result: "Oops! We had an error" message is displayed

Info. from LiveHTTP Headers:

https://preview.addons.mozilla.org/en-US/firefox/addon/161727/

GET /en-US/firefox/addon/161727/ HTTP/1.1
Host: preview.addons.mozilla.org
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.4) Gecko/20100513 Firefox/3.6.4
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive
Referer: https://preview.addons.mozilla.org/en-US/firefox/search/?sort=newest&pp=20&atype=0&pid=1&lver=any&cat=all
Cookie: WT_FPC=id=28dcb8a8d6c787250fa1274635177908:lv=1274819351086:ss=1274816967499; wtspl=570661; amo_home_promo_seen=5

HTTP/1.1 500 INTERNAL SERVER ERROR
Server: Apache
X-Backend-Server: pm-app-amo24
Vary: Accept-Encoding
Content-Type: text/html; charset=utf-8
Content-Encoding: gzip
Date: Wed, 26 May 2010 10:00:53 GMT
Via: Moz-Cache-zlb02
Connection: close
X-Cache-Info: not cacheable; response code not cacheable
----------------------------------------------------------
(Reporter)

Comment 1

8 years ago
The behavior noticed is seen on:
Windows and MACOSX platforms
OS: All → Mac OS X
(Reporter)

Comment 2

8 years ago
Another add-on noticed with this issue is:
https://preview.addons.mozilla.org/en-US/firefox/addon/91005/
(Reporter)

Updated

8 years ago
Summary: 500 Internal Server Error while navigating to add-on details page → 500 Internal Server Error while navigating to add-on details page on Windows and MACOSX platforms
Target Milestone: --- → 5.11
OS: Mac OS X → All
Hardware: x86 → All
 File "/data/amo_python/www/preview/zamboni/vendor/src/django-cache-machine/caching/base.py", line 138, in cache_objects
   cache.add(query_key, objects, timeout=self.timeout)

 File "/data/amo_python/www/preview/zamboni/vendor/packages/django-pylibmc/django_pylibmc/memcached.py", line 57, in add
   return self._cache.add(smart_str(key), value, self._get_memcache_timeout(timeout))

ServerError: error 10 from memcached_add: SERVER ERROR
Over in SUMO land, James had to revert from using pylibmc, because we were seeing the same error.
(Assignee)

Updated

8 years ago
Assignee: nobody → jbalogh
Summary: 500 Internal Server Error while navigating to add-on details page on Windows and MACOSX platforms → ServerError: error 10 from memcached_add: SERVER ERROR
(Assignee)

Comment 5

8 years ago
Since this is trying to store a list of 150 add-ons, I'm guessing we're trying to stick more than 1M in memcached.  It doesn't like that.

 File "/Users/jeff/dev/zamboni/apps/addons/views.py", line 86, in extension_detail
    author_addons = [a for a in author_addons if a.id != addon.id]

  File "/Users/jeff/dev/zamboni/vendor/src/django/django/db/models/query.py", line 104, in _result_iter
    self._fill_cache()

  File "/Users/jeff/dev/zamboni/vendor/src/django/django/db/models/query.py", line 755, in _fill_cache
    self._result_cache.append(self._iter.next())

  File "/Users/jeff/dev/zamboni/vendor/src/django-cache-machine/caching/base.py", line 129, in __iter__
    self.cache_objects(to_cache)

  File "/Users/jeff/dev/zamboni/vendor/src/django-cache-machine/caching/base.py", line 138, in cache_objects
    cache.add(query_key, objects, timeout=self.timeout)

  File "/Users/jeff/dev/zamboni/vendor/packages/django-pylibmc/django_pylibmc/memcached.py", line 57, in add
    return self._cache.add(smart_str(key), value, self._get_memcache_timeout(timeout))

ServerError: error 10 from memcached_add: SERVER ERROR
(Assignee)

Updated

8 years ago
Duplicate of this bug: 567882
(Assignee)

Comment 7

8 years ago
Fixed our heavy queries in http://github.com/jbalogh/zamboni/commits/b9996cd9b

Made pylibmc catch errors in http://github.com/jbalogh/django-pylibmc/commit/9f59ddf7d686
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified FIXED on https://preview.addons.mozilla.org/en-US/firefox/addon/161727/.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.