espn needs to use same case on HTML anchor IDs and CSS ID selectors

VERIFIED DUPLICATE of bug 24409

Status

Tech Evangelism Graveyard
English US
P3
normal
VERIFIED DUPLICATE of bug 24409
18 years ago
3 years ago

People

(Reporter: ekrock's old account (dead), Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

18 years ago
Chris Waterson wrote:

> http://college.espn.go.com/ncf/index
>
> Is it just me, or is this page not showing up right in seamonkey?

The principal reason that that page is not laying out as the author intended is
that they are specifying the ID in upper case, but using ID selectors in lower
case. Since the ID attribute is case-sensitive in HTML, then the selector will
not match if it uses a different case from the document.

I believe that mozilla is behaving per spec, but correct me if I'm wrong. (I
imagine though that this rule will trip up more than one web author because "...
but it works in IE" ")

John

<html>
<head>
<style>
  #ONE { border: 1px solid red; }  /* selector in UPPER CASE */
  #two { border: 1px solid red; }  /* selector in lower case */
</style>
</head>
<body>
  <div id="one">does this have a border?</div>  <!-- id value in lower
case -->
  <div id="two">does this have a border?</div>  <!-- id value in lower
case -->
</body>
</html>

Comment 1

18 years ago
I wanted to implement a quirk to make ID and CLASS case-insensitive but that 
would have required a big hack and the problem was closed as WontFix. See bug 
35522 for more info.

Comment 2

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Hardware: PC → All

Comment 3

18 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
(Assignee)

Comment 4

17 years ago
I have contacted them regarding this issue already.

*** This bug has been marked as a duplicate of 24409 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified dupe
Status: RESOLVED → VERIFIED
(Assignee)

Comment 6

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.