Requires new Firefox version add-on type do not show Upgrade Firefox link

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: Pratibha, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 447512 [details]
Older version of Firefox do not show upgrade firefox link

Browser tested:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Steps to reproduce:
-------------------
1) Load the add-on details page:
https://preview.addons.mozilla.org/en-US/firefox/addon/11009/
2)There is "Download Now" button
3)Click on it:pops up Software Installation window and install the add-on

Expected Result: As per SPECS: http://people.mozilla.com/~fligtar/zamboni/designs/2010-02-17/Button-Matrix-110217.png
There should be:
-"Add to Firefox" button and On-Click 
-Information window should pop-up with links to "Upgrade Firefox" or to "View older versions of this add-on"

Actual Result: add-on installation is done but after compatibility checks throws error that it's not compatible with older version and states work with Firefox versions
(Reporter)

Updated

8 years ago
The js broke because Fx 2.0 doesn't have JSON.  We really don't care what happens on Fx 2.0 anymore.  The web has moved on.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.