Closed Bug 568234 Opened 10 years ago Closed 10 years ago

Weave busted with js-based Form Manager

Categories

(Cloud Services :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 568256

People

(Reporter: johnath, Unassigned)

Details

Paul and Dolske landed the js-based form manager yesterday (bug 439716) and today's nightlies are busted in form-manager-related ways. The search box will do suggests, but hitting enter doesn't submit, and form entry in content doesn't offer suggestions. The console reports:

stmt is undefined in nsFormAutoComplete.js

(in the finally block of getAutoCompleteValues), and there's a Components.classesByID failing in what I suspect is weave code.

Dunno whether this fix will be weave-side or toolkit-side (hence the CCs!) but we should fix this... quickly.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 568256
Component: Needs Triage → General
QA Contact: needstriage → general
You need to log in before you can comment on or make changes to this bug.