Ability to scroll long address list in To: or CC: fields in header pane

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P1
major
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: Erich 'Ricky' Iseli, Assigned: BenB)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+ 2/13]UE1)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001013
BuildID:    2000101320

By default, if  many addresses are in the TO or CC field, only the two first
lines of the addresses are shown. If you want to see all addresses, you can
click on the triangle before the first address. If you have really many
addresses, the last ones disappear at the bottom of the screen. There is no way
to scroll this list (PgUp/PgDn, Scrollbar, arrows up and down)

Reproducible: Always
(Reporter)

Comment 1

17 years ago
Created attachment 17246 [details]
Screenshot (e-mail addresses voluntarily made unreadable)
(Reporter)

Comment 2

17 years ago
Created attachment 17250 [details]
Proposed modification (modified screenshot)

Comment 3

17 years ago
hmm this was really what bug 32055 was about, but it's marked fixed.

Comment 4

17 years ago
Bug 32055 was about never being able to see the *message* with a long list of 
addresses, because the twisty was off-screen -- and it was fixed. This bug, on 
the other hand, is about never being able to see the bottom-most *addresses*.

I suggest that rather than having a separate scrollbar for the address panel, 
this bug be fixed by making the addresses scroll with the message, like they did 
in 4.x. As jglick said in bug 32055 on 2000-03-01: `The envelop area should 
scroll with the message.  This was agreed upon a long time ago and is stated in 
the UE spec.'
OS: Windows 98 → All

Comment 5

17 years ago
Add keyword mail3 so this will be considered for 6.5 release. Also add UE1 
keyword since I feel this really affects the usability of the Mail client.

Bug 32055 was a temporary solution to this problem. We should try and 
implement a better solution if possible.

As stated in bug 32055: The envelope area should scroll with the message.  This 
was agreed upon a long  time ago and is stated in the UE spec. 

This eliminates the complexity of potentially 2 scroll bars in the message area 
(yuk) and having to remember whether the envelop area was expanded or collapsed 
previously.

It also allows the user to scroll the header info out of the way and be able to 
view more of the message (without an additional scrollable area taking up 
space).  Once the user has read the header info, they don't need to always be 
able to see it as they read the message.
Keywords: mail3, UE1

Comment 6

17 years ago
reassigning to mscott
Assignee: putterman → mscott

Comment 7

17 years ago
changing qa to nbaca 3-pane issue
QA Contact: esther → nbaca

Comment 8

17 years ago
marking nsbeta1+. ideally we'd like to scroll the headers with the message.
Keywords: nsbeta1
Priority: P3 → P1
Whiteboard: [nsbeta1+]

Comment 9

17 years ago
*** Bug 59988 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
moving to mozilla0.8 milestone.
Target Milestone: --- → mozilla0.8

Comment 11

17 years ago
evaughan and I aren't sure it's technicall possible to get an iframe to scroll
within a xul box without making core layout depend on XUL. Even then iframes
just don't work in a way where they know things about their parent.

moving to mozilla.9 although there are no guaruntees there either. 
Target Milestone: mozilla0.8 → mozilla0.9

Comment 12

17 years ago
marking nsbeta1- and moving to future.

It sounds like this isn't going to be possible in the short term.  If you guys
come up with a solution to this then we can try to get it into mozilla0.9
Keywords: nsbeta1 → nsbeta1-
Whiteboard: [nsbeta1+] → [nsbeta1+ 2/13]
Target Milestone: mozilla0.9 → Future

Updated

17 years ago
Keywords: ui
Summary: There is no way to scroll a very long list of addresses in a mail header → [RFE] Ability to scroll long address list in To: or CC: fields

Updated

17 years ago
Keywords: UE1
Whiteboard: [nsbeta1+ 2/13] → [nsbeta1+ 2/13]UE1
*** Bug 97594 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
A bug I submitted earlier today (97594) was just duped to this bug.  However, I
don't believe them to be quite the same problem.  This bug deals with recipient
lists that are too long vertically.  97594 deals with recipient lists that are
too long horizontally.  Scroll bars would fix both problems, but both veritcal
and horizontal scrolls are needed.

Comment 15

17 years ago
*** Bug 97547 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: nbaca → olgam
*** Bug 99374 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 99374 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
*** Bug 104022 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 122745 has been marked as a duplicate of this bug. ***
*** Bug 106678 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
*** Bug 102948 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
*** Bug 130830 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
*** Bug 92098 has been marked as a duplicate of this bug. ***

Comment 24

16 years ago
*** Bug 111161 has been marked as a duplicate of this bug. ***

Comment 25

16 years ago
*** Bug 150638 has been marked as a duplicate of this bug. ***

Comment 26

16 years ago
whoa, this was opened about 2 years ago! any news on getting this fixed?
bug still reproducible?
(Reporter)

Comment 27

16 years ago
Oh! already 2 years? then it must have been one of my first bug reports...

Yes, I still can repro this bug with Mozilla 1.1. The addresses are still not
scrolling with the content.

On a side note, if you have a lot of addresses, but not enough to repro this
bug, you will see that first the message list in the above pane gets reduced
until it has 0 size, then only the addresses (if all are shown), start to grow
downwards and eventually completely hide the body (including the scrollbar).
*** Bug 183701 has been marked as a duplicate of this bug. ***

Comment 29

15 years ago
This needs to be fixed. It's been 2 1/2 years now! This is the kind of bug that
makes mozilla look bad. A user should not have to view the source of the message
just so they can see all of the recipiants of a message. And, although I don't
know a lot a ton about programing, it seems like this is an easy fix, just put
the To: field into a scroll pane if it is over 100 or so recipiants. Am I wrong
about this beaing any easy fix?

Updated

15 years ago
Summary: [RFE] Ability to scroll long address list in To: or CC: fields → Ability to scroll long address list in To: or CC: fields in header pane

Comment 30

15 years ago
*** Bug 216605 has been marked as a duplicate of this bug. ***

Comment 31

15 years ago
This looks like the right bug. The headers are too large to view on the screen.
Working with x-headers for x-spam and x-virus at the bottom of the headers page,
you cant see them.  Using client side mail programs that alter the x-headers is
on the bottom of the header display, and you cant see it, you cant scroll
through the headers.  The whole TO/CC/Header display is also small on large
email distributions. 

Comment 32

14 years ago
Now 3 years old this bug, and still marked as NEW! I think this is a serious
bug. As one commenter said it's really a black eye on the mail interface. Makes
it look broken. There must be some solution.

Comment 33

14 years ago
*** Bug 231451 has been marked as a duplicate of this bug. ***

Comment 34

14 years ago
*** Bug 233132 has been marked as a duplicate of this bug. ***

Comment 35

14 years ago
Created attachment 140819 [details]
4th birthday of this bug, 25 duplicates, reproducable in moz1.6

Comment 36

14 years ago
*** Bug 235754 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Attachment #140819 - Attachment is obsolete: true
(Assignee)

Comment 37

14 years ago
New URL for spec: <http://www.mozilla.org/mailnews/specs/threepane/#Envelope>
"The envelope area should scroll with the message body."

Comment 38

14 years ago
Strictly speaking, that's bug 9942, not this one.

Comment 39

14 years ago
*** Bug 243903 has been marked as a duplicate of this bug. ***

Comment 40

14 years ago
*** Bug 245969 has been marked as a duplicate of this bug. ***

Comment 41

14 years ago
*** Bug 244308 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Assignee: mscott → ben.bucksch
(Assignee)

Comment 42

14 years ago
See bug 9942, a fix for that would solve this one, too, and I think I have one.
Status: NEW → ASSIGNED
Target Milestone: Future → mozilla1.8alpha2

Comment 43

14 years ago
*** Bug 254245 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Depends on: 9942

Comment 44

13 years ago
Still there in 1.7!
Product: Browser → Seamonkey
*** Bug 277100 has been marked as a duplicate of this bug. ***

Comment 46

13 years ago
xref TB bug 223132

Comment 47

12 years ago
This will be fixed when bug 223132 is fixed. Actually, one can fix it now just using the version 2.0 of headerScroll [*]. 

So, why not mark this as a duplicate, or link them somehow? 

[*] http://www.cweiske.de/misc_extensions.htm#headerScroll

Comment 48

11 years ago
> Severity: 	 enhancement

This isn't an enhancement.  It's a bug.  An existing feature (displaying
message headers) does not work as it should (handling arbitrarily long data).

(Assignee)

Updated

11 years ago
Severity: enhancement → major

Updated

11 years ago
Duplicate of this bug: 375059

Comment 50

11 years ago
Ok I think this is related I have a post @ http://forums.mozillazine.org/viewtopic.php?t=573693

"
Hi Folks

I have a problem where I can't read the long lines in the 'extended headers' in an email as the container doesn't have a horizontal scroll bar.

I have found a work around :

in userChrome.css I have put

#expandedHeaderView{
min-width:300em !important;
}

This 300em makes the container so big that a horizontal scroll bar is forced. I just can't see why the inner text in the container didn't make a horizontal scroll bar. 

"
Assignee: ben.bucksch → mail
Status: ASSIGNED → NEW
Priority: P1 → --
QA Contact: olgam
Target Milestone: mozilla1.8alpha2 → ---
(Assignee)

Updated

10 years ago
Assignee: mail → ben.bucksch
Priority: -- → P1
Duplicate of this bug: 490089

Updated

9 years ago
QA Contact: message-display

Comment 52

8 years ago
SM2 shows a vertical scroll bar in message header pane.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 53

8 years ago
Hmmm, the mail header remains fixed height size in classic theme. An chance to make it automatically (say 50%) bigger if the vertical scroll bar is displayed?

Comment 54

8 years ago
That needs another bug. File one if you can't find an existing bug for this. 

Note that still some issues exist on resizin0g, Bug 55368 et al.
You need to log in before you can comment on or make changes to this bug.