If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make BzAPI cache the config and support the 304 Not Modified response config.cgi now supplies

RESOLVED DUPLICATE of bug 566343

Status

Webtools
BzAPI
--
enhancement
RESOLVED DUPLICATE of bug 566343
7 years ago
7 years ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

7 years ago
config.cgi can now return a 304 Not Modified instead of data. This confuses the BzAPI.

Fixing this is probably connected to fixing bug 566343.

Gerv
(Assignee)

Comment 1

7 years ago
This bug is somewhat confused. By default the REST API will never see the 304, because it doesn't send the right headers. But it should cache the result, and send the headers, for a speed win.

Gerv
Severity: normal → enhancement
Summary: Make BzAPI support the 304 Not Modified response config.cgi now supplies → Make BzAPI cache the config and support the 304 Not Modified response config.cgi now supplies
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566343
You need to log in before you can comment on or make changes to this bug.