Undo-ing a delete in an IMAP-Subfolder undoes two deletes

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Veeck, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: 3.04

I got an Imap-account with subfolders. if i delete two messages and undo the last deletion, the first deletion is also undone. this happens as far as i can see only in subfolders and not the main-folder of the imap-account.

Reproducible: Always

Updated

8 years ago
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Version: unspecified → 3.0
So you action is :

Select message 1
delect message 1
Select message 2
delete message 2
undo

or 
Select message 1+2
delete 
undo
(Reporter)

Comment 2

8 years ago
My actions are:

Select message 1
delete message 1
Select message 2
delete message 2
undo
This is WFM for Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1.

Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)
(Reporter)

Comment 4

8 years ago
just tried safe-mode, doesnt help though, problem still persists. 

could be something wrong with my mail-database? because when i start i also have the problem that thundebird shows in "activities" that the messages in the send-folder are being determined. that activity never comes to an end but tb hangs for several seconds during startup.

Comment 5

8 years ago
veeck, do you see this with version 3.1.2?
(Reporter)

Comment 6

8 years ago
with 3.1.2 i dont see this bug anymore. i will close it therefore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

3 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.