Stats Exception indicator

RESOLVED FIXED in 6.3.8

Status

addons.mozilla.org Graveyard
Statistics
P3
normal
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: fligtar, Assigned: potch)

Tracking

Details

(Reporter)

Description

8 years ago
We occasionally have problems with AMO or logs that cause blips in our data. Right now I usually post to our blog and put out a story on the developers' newsfeed, but not everyone sees that and it'd be good to have it where the data is.

I'd like the ability to associate a short message and URL with an exception date that appears on the stats dashboard. So if I look back at May 25 and want to know why there was a large drop, I can see that AMO was down for 2 hours and read more.

I think this would best be presented on hover of that day in the graphs, but if that's too hard technically, perhaps in the sidebar we can show any exceptions from the last week and a link to view all past exceptions.

Chowse, do you have any ideas for how this could go into the new stats dashboard nicely?
Highcharts supports arbitrary symbols:

   http://highcharts.com/demo/?example=spline-symbols&theme=default

For data points that contain questionable data, we could replace the marker with a warning icon (http://bit.ly/cxwVcm) or flags (http://bit.ly/bGHHq). Hovering over the data point reveals a data tooltip, which can include a short description. Clicking on the symbol could open a URL to the relevant blog post.

This strikes me as the most elegant solution, but it has 2 ugly edge cases:

1. If the user looks at data over an extended period of time, or there is a
   sudden recurrence of these events, the chart could get overwhelmed with
   these special symbols.

2. If we're looking at a chart that aggregates data over certain periods
   (e.g. weekly or monthly views), do we still show these symbols? Or does the
   data get smoothed out? Perhaps only if it crosses a certain threshold?
(Reporter)

Comment 2

8 years ago
Sweet, thanks chowse!

potch, do you think you can work up something from that?
Assignee: chowse → mclaypotch
(Assignee)

Updated

8 years ago
Assignee: mclaypotch → thepotch
(Assignee)

Updated

7 years ago
Target Milestone: --- → 5.11.4
(Assignee)

Updated

7 years ago
Target Milestone: 5.11.4 → 5.11.5
Target Milestone: 5.11.5 → 4.x (triaged)
(Assignee)

Comment 3

6 years ago
This is coming along- I'm using a combination of highlighted regions, custom symbols, and a shiny-new admin panel to get all this done. Should land in a rough form this week.
Target Milestone: 4.x (triaged) → 6.3.7
Target Milestone: 6.3.7 → 6.3.8
(Assignee)

Comment 4

6 years ago
https://github.com/mozilla/zamboni/commit/71a38d5 

w00t
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 734238
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.