Fennec js will not link on OSX 10.6 when compiling using Android NDK

RESOLVED DUPLICATE of bug 571695

Status

--
minor
RESOLVED DUPLICATE of bug 571695
9 years ago
8 years ago

People

(Reporter: paul.esson, Unassigned)

Tracking

Trunk
x86
Mac OS X

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_3; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.55 Safari/533.4
Build Identifier: Version Control - 25-May-2010

Following instructions found https://wiki.mozilla.org/Mobile/Fennec/Android#JS.2FNSPR_only results in a linking error, the ./configure includes -lobjc ( objectivec library ) and the compile fails since this is not included in the NDK.

 

Reproducible: Always

Steps to Reproduce:
1.Follow https://wiki.mozilla.org/Mobile/Fennec/Android#JS.2FNSPR_only
2.When in js section, the compile will fail in the 'make -s' command.
3.ld will tell you libobjc was not found. 
Actual Results:  
build fails with following error

/Users/pont/android/android-ndk-r4/build/prebuilt/darwin-x86/arm-eabi-4.4.0/bin/../lib/gcc/arm-eabi/4.4.0/../../../../arm-eabi/bin/ld: cannot find -lobjc
collect2: ld returned 1 exit status
make[1]: *** [libmozjs.so] Error 1
make: *** [default] Error 2

Expected Results:  
Expected it to link.

removing -lobjc from OS_LDFLAGS in js/config.autoconf.mk allowed js to compile and run on phone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 571695
You need to log in before you can comment on or make changes to this bug.