Closed Bug 568685 Opened 11 years ago Closed 10 years ago

about:blank does not refresh thumbnail image in left sidebar

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 6

People

(Reporter: azakai, Assigned: vingtetun)

References

Details

Attachments

(1 file)

Steps to reproduce:

1. Run fennec.
2. Go to about:blank.
3. Slide in the left sidebar, to see the thumbnails. The page being viewed is about:blank, but the thumbnail for this tab is still that of the previous page (about:home).

The same will occur if you go to about:blank after any other website - the thumbnail will be the previous page's.

This is on Fennec trunk (non-e10s) on Ubuntu 10.04.
This issue is still reproducing on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.2a1pre)Gecko/20110412
Firefox/4.2a1pre Fennec /4.1a1pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1

Steps:
1. Go to about:fennec
2. Tap on Know Your Rights
3. Tap on system Back button
4. Slide in the left sidebar, to see the thumbnail

I guess that this issue is reproducing for all about: pages.
Attached patch PatchSplinter Review
The about:blank check come from bug 527986 and the code has moved since to FirstPaint (bug 639102) so I think there is no need to check for it anymore
Assignee: nobody → 21
Attachment #525850 - Flags: review?(wjohnston)
Attachment #525850 - Flags: review?(wjohnston) → review+
do we have any browser-chrome thumbnail tests for this kinda thing?
OS: Linux → All
Hardware: x86 → All
http://hg.mozilla.org/mozilla-central/rev/ad0261d9618d(In reply to comment #4)

> do we have any browser-chrome thumbnail tests for this kinda thing?

I don't think so.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I can still reproduce the issue from comment 2 .. . 

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110513 Firefox/6.0a1 Fennec/6.0a1 

Device: HTC Desire Z (Android 2.2)

reopening the bug ....
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment 2 is a different bug, this one was about about:blank.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
VERIFIED FIXED on:

Build ID: Mozilla/5.0 (Maemo; Linux armv7l; rv:6.0a1) Gecko/20110510
Firefox/6.0a1 Fennec/6.0a1

Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110515 Firefox/6.0a1 Fennec/6.0a1 


Mozilla /5.0 (Android;Linux armv7l;rv:5.0a1) Gecko/20110515 Firefox/5.0a2 Fennec/5.0a2 

Devices: Nokia N900(Maemo GTK), HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 6
You need to log in before you can comment on or make changes to this bug.