NS6: no scrollbar when viewing indiv. search engine results after performing aggregate search

VERIFIED DUPLICATE of bug 55334

Status

()

Core
Layout
P2
normal
VERIFIED DUPLICATE of bug 55334
18 years ago
17 years ago

People

(Reporter: Lynn Webb, Assigned: buster)

Tracking

({testcase})

Trunk
mozilla0.9
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When user performs aggregate search, no scrollbar is available when the user 
views the result pages for the individual search engines.

Steps to reproduce:
1. select two or more search engines from the sidebar search panel.
2. enter search query in sidebar and click on Search button
3. In the main browser window, select a search engine by clicking on the 
corresponding button.
4. Note that you can see the results page, but that you cannot scroll down the 
list because the scrollbar is missing on the right-hand side of the browser 
window.
(Reporter)

Updated

18 years ago
Keywords: rtm
Priority: P3 → P2

Comment 1

18 years ago
Multi-engine searchs are currently broken and its being tracked in bug # 55277

*** This bug has been marked as a duplicate of 55277 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
I wouldn't exactly call this a dupe and I'd like to see the fix for that bug first. This bug
is one level deeper and it's not a matter of course to assume one fixes the other.
Of course you may very well fix this while fixing that. That's just fixing two bugs though,
not the same bug twice (ie a duplicate).

I'm going to reopen this and jsut sit and wait for 55277.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [rtm-]
Duplicate or not, bug 55277 has been minused so I guess this one should be too.

Comment 4

18 years ago
Probably just needs a CSS tweak... Ben?
Assignee: rjc → ben
Status: REOPENED → NEW
Whiteboard: [rtm-]

Comment 5

18 years ago
Ouch.  Ben, have a look see at this puppy ...
Whiteboard: [rtm need info]

Comment 6

18 years ago
Sigh.  At this point in the RTM cycle I'm gonna have to minus this.  If anyone
comes up with a patch, please clear the minus.
Whiteboard: [rtm need info] → [rtm-]

Comment 7

18 years ago
wow. this sucks. taking a look...
Assignee: ben → blakeross

Comment 8

18 years ago
I don't think this is an XPApps bug.

Here's what we do:

	var doc = frames[0].document;
	doc.open("text/html", "replace");
	doc.writeln(text);
	doc.close();

which is fine.  It seems that if you use doc.writeIn to write in enough content 
such that a scroll is required, the scrollbar won't properly appear.  Seems 
like a layout bug, punt back if you disagree.  I'll attach a testcase.
Assignee: blakeross → clayton
Component: Search → Layout
QA Contact: claudius → petersen

Comment 9

18 years ago
Created attachment 17983 [details]
minimized testcase

Comment 10

18 years ago
*** Bug 57974 has been marked as a duplicate of this bug. ***
Dividing up Clayton's bugs to triage
Assignee: clayton → dcone

Comment 12

18 years ago
Triage.. I think this is in layout..
Assignee: dcone → buster
(Assignee)

Comment 13

18 years ago
two comments:
1) I've seen other bugs like this, where js-written content fails to produce a
scrollbar.
2) I tried the steps to reproduce, and I got scrollbars.  On WinNT, using
20001106 rtm candidate build.
Status: NEW → ASSIGNED

Comment 14

18 years ago
*** Bug 58833 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
Testcase fails for me. WinNT build 20001128

Found this while investigating a similar bug. The test case here is exactly what
I'm seeing: writing to the document will not trigger a scroll bar when needed.
This occurs in both frames and opened windows.

Resizing does not pick up the new document size either. Apparently no way to get
the scrollbar to appear.



Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase
(Assignee)

Comment 17

18 years ago
probably a duplicate of bug 55334
Target Milestone: --- → mozilla0.9

Comment 18

18 years ago
agreed.  marking dependency for now.
Depends on: 55334

Comment 19

17 years ago
Defintely a dup.

*** This bug has been marked as a duplicate of 55334 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 20

17 years ago
Verifications.  Tests (if necessary) were done with 2001052504 on Windows 2000.

Please forgive the spam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.