The default bug view has changed. See this FAQ.

moz-appearance: progresschunk overflows on the bottom

VERIFIED FIXED in mozilla6

Status

()

Core
Widget: Win32
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

Trunk
mozilla6
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 3 obsolete attachments)

(Assignee)

Description

7 years ago
Created attachment 448005 [details]
Test case

It looks like moz-appearance: progresschunk overflows on the bottom. It seems the overflow is a constant value of pixels I didn't check more than that but it's not a percentage.
This is working correctly with the GTK widget.
(Assignee)

Comment 1

7 years ago
Created attachment 448007 [details]
Test case

Updating the test case, the overflow was misplaced.

And I confirm this bug appears on Windows XP too.
Attachment #448005 - Attachment is obsolete: true
(Assignee)

Comment 2

7 years ago
Created attachment 448008 [details]
Screenshot on Windows 7
(Assignee)

Updated

6 years ago
Assignee: nobody → mounir.lamouri
Blocks: 633207
(Assignee)

Comment 3

6 years ago
Created attachment 519137 [details] [diff] [review]
Patch v1
Attachment #519137 - Flags: review?(doug.turner)
(Assignee)

Updated

6 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Whiteboard: [needs review]
(Assignee)

Updated

6 years ago
Blocks: 641517
(Assignee)

Comment 4

6 years ago
Created attachment 519433 [details] [diff] [review]
Patch v1.1

This is fixing a warning (11.f should be 11).
Attachment #519137 - Attachment is obsolete: true
Attachment #519433 - Flags: review?(doug.turner)
Attachment #519137 - Flags: review?(doug.turner)

Comment 5

6 years ago
is 11 defined somewhere?  Can we get this value dynamically?

widgetRect.bottom -= 11;
(Assignee)

Comment 6

6 years ago
No, 11 is defined nowhere. I found that by trying multiple values and reftesting with an element with overflow: hidden. The overflow is constant and doesn't seem to be dynamic. The "small" version of the reftest is here to prove that.

I wonder if the overflow comes from a bug somewhere else but the way we draw progress bars seems quite simple and I don't understand what would create it.
(Assignee)

Updated

6 years ago
Attachment #519433 - Flags: review?(doug.turner) → review?(jmathies)
(Assignee)

Comment 7

6 years ago
Created attachment 519971 [details] [diff] [review]
Patch v1.2

With a static const.
Attachment #519433 - Attachment is obsolete: true
Attachment #519971 - Flags: review?(jmathies)
Attachment #519433 - Flags: review?(jmathies)
(Assignee)

Comment 8

6 years ago
Hmmm, so my patch is working as a workaround but obviously the issue is somewhere else... If you open: data:text/html,<progress tabindex=1 value=1></progress>
and click on (or tab on) the progress element, you will see the outline taking more than the progress' size. But I still have no idea where this comes from given that Windows is the only widget with that issue.

Comment 9

6 years ago
Comment on attachment 519971 [details] [diff] [review]
Patch v1.2

Review of attachment 519971 [details] [diff] [review]:

Hard coded values sucks, but I suppose it will flesh itself out over time.
Attachment #519971 - Flags: review?(jmathies) → review+

Updated

6 years ago
Whiteboard: [needs review]
(Assignee)

Updated

6 years ago
Whiteboard: [ready to land][waits for dependencies]
(Assignee)

Updated

6 years ago
Blocks: 654709
(Assignee)

Comment 10

6 years ago
Pushed:
http://hg.mozilla.org/mozilla-central/rev/65a4097a0d95
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [ready to land][waits for dependencies]
Target Milestone: --- → mozilla6

Updated

6 years ago
Depends on: 655860
Backed out in http://hg.mozilla.org/mozilla-central/rev/dd9ba28d2bd9 to resolve bug 655860.

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

6 years ago
The regression wasn't caused by these patches. Re-landed:
http://hg.mozilla.org/mozilla-central/rev/50a3b89cce71
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Flags: in-testsuite+
(Assignee)

Updated

6 years ago
No longer depends on: 655860

Updated

6 years ago
Depends on: 656284

Updated

6 years ago
Depends on: 658885

Comment 13

6 years ago
Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0

Verified issue using attached Testcase on Win7 and WinXP. Everything is in order -> setting status to Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.