Some linebreaks missing when copy&paste

VERIFIED DUPLICATE of bug 56561

Status

()

Core
Serializers
P3
critical
VERIFIED DUPLICATE of bug 56561
18 years ago
18 years ago

People

(Reporter: Daniel Bratell, Assigned: Akkana Peck)

Tracking

({dataloss})

Trunk
Future
x86
Windows 2000
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I tried to copy the code on
http://codeguru.earthweb.com/internet/IsINetConnection.shtml
 and then pasting it in another application (Visual Studio's editor) but got
some assertions during the paste saying "Mixing cached and not cached data" or
something like that.

The I noticed that the pastead text missed at least a couple of line breaks on
lines starting with // (a C++ comment), making the code end up in a comment.

I wonder if this can be caused by the NOXIF landing. A major bug it is anyway.

I have no time to look at it myself, but I think it might be quite easy to fix.
Might.

This was with a build from CVS 2000-10-14 (I think. Might be 2000-10-15 or
2000-10-13) on Windows 2000.
(Reporter)

Updated

18 years ago
Keywords: dataloss
(Reporter)

Comment 1

18 years ago
This is on the trunk btw. I have not tested any branch build.

Updated

18 years ago
Summary: Data corrupted when copy'n'paste → Soem linebreaks missing when copy&paste

Comment 2

18 years ago
Could be related to bug 56561

Comment 3

18 years ago
moving out to future
Summary: Soem linebreaks missing when copy&paste → Some linebreaks missing when copy&paste
Target Milestone: --- → Future
(Assignee)

Comment 4

18 years ago
Probably not related to bug 56561 -- I dont' see the "mixed wrapping and
non-wrapping" asserts in that bug which Daniel reports in this one.  I don't
know what's going on in this one (haven't had a chance to look).  Though the
missing linebreaks might be solved by the fix for that bug (Daniel, if you get a
chance to apply that patch, it would be great to know whether it helps).
(Reporter)

Comment 5

18 years ago
I looked at this in the debugger and the assertions appear right at the spot 
your patch touches. I'm building right now but I'm quite sure it's a dupe. I 
will mark it as such as soon as I've checked your patch.
(Reporter)

Comment 6

18 years ago
This was the same bug as bug 56561 and was fixed by the patch to it. I noticed 
another bug and opened bug 57047 for it.


*** This bug has been marked as a duplicate of 56561 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
verified in 10/17 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.