get "Already running...." dialog if default profile not found

VERIFIED DUPLICATE of bug 278860

Status

()

Toolkit
Startup and Profile System
VERIFIED DUPLICATE of bug 278860
8 years ago
8 years ago

People

(Reporter: Jeff Hammel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
So I found this writing a XUL app.  To kill cache, I aggressively just killed the generated profile.  However, because it is still listed in the profiles.ini for this application, I get the very misleading error message:

"""
ProfileManager is already running, but is not responding. To open a new window, you must first close the existing ProfileManager process, or restart your system.
"""

NOTE: the process is definitely not running.  Looking through with strace, it seems like it dies on a "Resource temporarily unvailable".

I tried this with Firefox (3.6.4, but I doubt this is fixed in trunk), and sure enough, same issue.  I made a dummy profile, 'foo', then I set it to default in profiles.ini:

"""
[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=utgk7vyo.default

[Profile1]
Name=foo
IsRelative=1
Path=j4vk7qwk.foo
Default=1
"""

Then I deleted foo's profile directory (before that it starts and shuts down fine)

Then running firefox gives me the expected "Firefox is already running..." message.  Which again, it isn't.  Try it for yourself (with a dummy profile of course).

At least the message should be fixed.  Ideally, it should take you to the ProfileManager or something with an alert message.

I'd be happy to help implement a fix since I'm already touching related code, if it is decided what to do.
(Reporter)

Updated

8 years ago
Component: XP Toolkit/Widgets: XUL → Startup and Profile System
Product: Core → Toolkit
QA Contact: xptoolkit.xul → startup
(Reporter)

Comment 1

8 years ago
This is a duplicate of 278860 (and 381139 and probably more).  Basically, this will happen whenever any XUL (XPCOM?) app is launched and the default profile is inaccessible (temporarily unavailable).  This is a pretty bad bug, an old one, and probably not very hard to at least fix the error message.  I'll take 278860 if desired and no one objects.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278860
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.