Empty folders should say something to that effect in the folder view

RESOLVED DUPLICATE of bug 492158

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED DUPLICATE of bug 492158
8 years ago
2 years ago

People

(Reporter: J.B. Nicholson-Owens, Unassigned)

Tracking

({ux-efficiency})

Trunk
ux-efficiency

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100403 Fedora/3.6.3-4.fc13 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9) Gecko/20100430 Fedora/3.0.4-3.fc13 Thunderbird/3.0.4

I think empty folders should be easier to spot.  In SquirrelMail, for example, if I select an empty folder the message list/body area of the screen says "THIS FOLDER IS EMPTY".  This provides a clear indication you're not waiting for a load but in fact looking at an empty folder.

Could Thunderbird do something similar when displaying empty folders?

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird on any account where you know you have at least one empty folder.
2. Select that folder.
3. Set the view pane layout so you can see the message list and/or body.
4. Notice how there's no clear indication that you're looking at an empty folder (as opposed to waiting for TB to load messages).
Actual Results:  
You see an empty list and body (which you might see if you were waiting for a folder with some messages to load).

Expected Results:  
I would have liked to get clear confirmation that I'm looking at an empty folder.

The words "This folder is empty" or something like that should appear vertically and horizontally centered in the body area.
Bryan might be a good idea to consider for the work on folder view.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ux-efficiency

Updated

5 years ago
Version: unspecified → Trunk

Comment 2

2 years ago
This will be happening in bug 492158 (whenever that lands, which is getting closer...)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492158
You need to log in before you can comment on or make changes to this bug.