Closed Bug 569105 Opened 10 years ago Closed 9 years ago

Intermittent crashtests/505912-1.html | assertion count 2 is more than expected 0 assertions (Should be playing: 'IsPlaying()')

Categories

(Core :: Audio/Video, defect)

x86
Windows Server 2003
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 564603

People

(Reporter: philor, Unassigned)

Details

(Keywords: assertion)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275191143.1275191771.31536.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/29 20:45:43
s: win32-slave38

REFTEST INFO | Loading file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/505912-1.html
++DOMWINDOW == 48 (0A069384) [serial = 2281] [outer = 048A17B8]
WARNING: ContentViewer exists outside gHistoryMaxViewer range: '!viewer', file e:/builds/moz2_slave/mozilla-central-win32-debug/build/docshell/shistory/src/nsSHistory.cpp, line 846
For application/x-test found plugin nptest.dll
WARNING: Connect called twice: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 178
### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to c:\docume~1\cltbld\locals~1\temp\tmp1u7n9y\runreftest_leaks_plugin_pid3320.log
###!!! ASSERTION: Should be playing: 'IsPlaying()', file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/media/nsBuiltinDecoderStateMachine.cpp, line 358
xul!gfxWindowsNativeDrawing::operator=+0x00000000000F032A
xul!NS_GetComponentRegistrar_P+0x0000000000005BBA
xul!Hunspell_free_list+0x0000000000093513
xul!NS_GetComponentRegistrar_P+0x0000000000004B5E
nspr4!PR_LockOrderedLock+0x000000000002ABF1
nspr4!PR_LockOrderedLock+0x000000000002F25F
MSVCR80D!beginthreadex+0x0000000000000221
MSVCR80D!beginthreadex+0x00000000000001C7
kernel32!GetModuleHandleA+0x00000000000000DF
###!!! ASSERTION: Should be playing: 'IsPlaying()', file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/media/nsBuiltinDecoderStateMachine.cpp, line 358
WARNING: Connect called twice: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 178
REFTEST TEST-PASS | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/505912-1.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
++DOMWINDOW == 49 (09FC165C) [serial = 2282] [outer = 048A17B8]
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/505912-1.html | assertion count 2 is more than expected 0 assertions
505912-1.html doesn't use any media tags, so I guess this assertion is actually from 481921-iframe.html (just added) or 501535-1.html.

Given the number of tests this assertion already affects (see bug 564603), I think we should downgrade it into a warning until it's fixed.  I don't really want to back out the test for bug 481921 because of this assertion.
Blocks: 569108
Downgraded from assertion to warning:
http://hg.mozilla.org/mozilla-central/rev/51fef780d71a
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564603
No longer blocks: 438871, 569108
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.