bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Viweing bookmarks does not release GDI handles

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: nightstalkerz, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

974.02 KB, application/octet-stream
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100530 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100530 Minefield/3.7a5pre

If you have a lot of bookmarks in one folder and you view them using the bookmarks menu, each favicon take up 1 GDI handle

Reproducible: Always

Steps to Reproduce:
1. Create a lot of bookmarks in 1 folder (~600+ bookmarks)
2. Use the bookmarks menu or the bookmarks manager and open the folder which contains the bookmarks or expand every folder to view the bookmarks
Actual Results:  
Each bookmark uses 1 GDI handle and is not released until Firefox closes.

Windows can become quite sluggish if there's a lot bookmarks.

Expected Results:  
The GDI handles are released when the bookmarks menu/manager closes or the try to keep the GDI handle down when viewing bookmarks like Chrome/Opera.

Might only occur with bookmarks with favicons which is probably quite common.

Comment 1

8 years ago
related to bug 472677 ?
(Reporter)

Comment 2

8 years ago
Looks very similar but according to comment #14, it should go away after a while but this doesn't appear to go away.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 3

7 years ago
Is this still an issue with Firefox 9.0.1?

If so, can you provide a backup of a folder that causes the issue?
(Reporter)

Comment 4

7 years ago
Created attachment 590465 [details]
places.sqlite zip

Replace the existing places.sqlite with this one
(Reporter)

Comment 5

7 years ago
Use the bookmarks menu item or the bookmarks toolbar button and hover over each folder so the bookmarks in them gets displayed.

The bookmarks manager does not have this issue.
this is actually expected, when opening a menu we keep its result alive, because that improves performances of navigating through menus. Though we may evaluate if it's still the case.

Updated

6 years ago
Depends on: 730340
Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130725 Firefox/25.0

No longer reproducible on latest Nightly (buildID: 20130725030212). If anyone does reproduce the issue please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.