Closed Bug 569185 Opened 9 years ago Closed 9 years ago

Rebootless extension doesn't show up in the list of extensions after being installed

Categories

(Toolkit :: Add-ons Manager, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 566626

People

(Reporter: ehsan, Unassigned)

Details

(Whiteboard: [AddonsRewrite])

I tried installing a rebootless extension, and noticed that after doing that, the Add-ons Manager page doesn't show it in the list of add-ons (even if I close and reopen it), but if I search for something inside the name of the extension, it shows up inside the search results.
Ehsan, I miss your build id? Are you using an outdated version of Minefield? Also about which Jetpack you are talking about? I miss that important information.
Whiteboard: [AddonsRewrite]
Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100527 Minefield/3.7a5pre

The extension was based on Jetpack SDK 0.4.
(In reply to comment #2)
> The extension was based on Jetpack SDK 0.4.

Can you please tell us which extension it is? It will help us drastically to find the reason. I can't see this problem with extensions located here: https://secure.toolness.com/xpi/restartless/
It's my Bugzilla Tweaks jetpack.  The extension isn't 100% ready for me to release, but I can send you the current XPI file in an email.  In fact, I'll do that right now.
(In reply to comment #2)
> Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
> rv:1.9.3a5pre) Gecko/20100527 Minefield/3.7a5pre

Please update your build to 100530. I'm sure it's fixed now. Can you verify that? It works at least for me.
It *seems* to be working for me now, but I had the extension installed in this profile before.  Let's just leave this open for Mossop to take a look.
Can you please test with a fresh profile to make sure nothing from the previous installation interferes here?
Unfortunately I didn't see this problem in another profile originally.  I don't think it's 100% reproducible on fresh profiles.
I'm also not able to reproduce it with a build from 05/27. Ehsan, it would be great if you could test the 05/27 build and try to find out reproducible steps. Given that you can't reproduce it 100% makes it hard to say it is fixed or not. Would be great if you could find some time.
I gave it a shot for about half an hour, and unfortunately I was not able to reproduce the problem again.
Short of any way to reproduce this I'm going to claim that it was probably a manifestation of bug 566626, it's certainly plausible and the reality is if we can't see it anymore we're not likely to make any progress on it.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566626
You need to log in before you can comment on or make changes to this bug.