while deleting text in input boxes, the page pans

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: dweiss2, Assigned: mbrubeck)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Linux; U; Android 2.1-update1; en-us; Droid Build/ESE81) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Mobile Safari/530.17
Build Identifier: fennec/build 5/30/2010

When I ty to delete text from an input box (such as this one) and my Motor Droid is in portrait mode the page pans up putting the input box behind the keyboard.  I have not tried it yet in landscape mode. I think this is a similar bug to 527187.

Reproducible: Always

Steps to Reproduce:
1. Put device in portrait mode
2. Choose a text box to delete text from
3. Press delete
Actual Results:  
The page pans up and the input box is not visable but the text is still deleted.

Expected Results:  
The page should not move.
Whiteboard: mobile-triage
(Assignee)

Updated

8 years ago
Assignee: nobody → mbrubeck
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Status: ASSIGNED → UNCONFIRMED
Ever confirmed: false
Whiteboard: mobile-triage
(Assignee)

Comment 1

8 years ago
Possibly related to bug 438764.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Linux → Android
Hardware: Other → ARM
(Assignee)

Comment 2

8 years ago
oops, I meant bug 544765
bug 544765 closed, can this be resolved?
(Assignee)

Comment 4

8 years ago
I am still seeing this bug.
bug 544765 actually pans the page to keep the caret in view. The code probably needs to be adjusted to handle the virt kdb affect.
tracking-fennec: --- → 2.0+

Comment 6

8 years ago
This is reproducible on Nokia N900 as well:
buildID: Mozilla/5.0 (Maemo; Linux armv7l; rv:2.0b8pre) Gecko/20101014 Firefox/4.0b8pre Fennec/4.0b2pre 
Changing platform
OS: Android → All

Comment 7

8 years ago
i don't see this.  has it been fixed?
(Assignee)

Comment 8

8 years ago
Yes, this seems to be fixed on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Adriana, can you please verify this bug?

Comment 10

8 years ago
Verified as fixed on the following sites:
bugzilla.mozilla.org
http://jquery.malsup.com/form/#fields

Device: Nokia N900
Build ID: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b9pre)Gecko/20110103 Firefox/4.0b9pre Fennec /4.0b4pre

Device: Motorola Droid 2
Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre Fennec /4.0b4pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.