Allow disabling Glass from about:config

RESOLVED INVALID

Status

()

Core
Widget: Win32
P4
normal
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: tymerkaev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

(Reporter)

Description

8 years ago
User-Agent:       
Build Identifier: 

Currently Glass can't be disabled, but users may want restore to default background (if they don't want it). Needed 2 booleans for browser and downloads.

Reproducible: Always

Comment 1

8 years ago
This feels like WONTFIX to me: complicated pref systems for marginal benefit. If you really don't want glass, you can turn it off at the OS level
Component: Shell Integration → Widget: Win32
Product: Firefox → Core
QA Contact: shell.integration → win32
This is actually quite difficult to do with a pref since it's done with CSS. Possible solutions:

a) We could ship a second theme but that sounds like a lot of work.
b) Personas don't appear to style the download manager but if they did, one of those will work.
c) It can also be overridden in userChrome.css.
(Reporter)

Comment 3

8 years ago
No, I mean add before and after changed lines @ifdef pref browser.aeroGlass.enabled @endif and set true by default.
We could look into having a pref to cause the :-moz-win-compositor pseudo selector never match. I'm not sure what the performance hit on that would be - probably minimal.
(Reporter)

Updated

8 years ago
Blocks: 544820
Depends on: 560516

Comment 5

8 years ago
Glass should be allowed to be disabled until it works properly with Direct2D.
I prefer Direct2D and DirectWrite to Aero.

Comment 6

8 years ago
For now , using persona disables it

Comment 7

8 years ago
No it doesn't. It just covers it. Directwrite is still broken then.
I'll be honest - this is a low priority bug for me. I've got very limited time before Firefox 4 ships and there are bigger fish I need to fry. That said, I think that fixing this bug as in comment #4 wouldn't be too hard if someone wanted to take a crack at it. Bonus points for making it a live pref.
Priority: -- → P4
Whiteboard: [good first bug]

Comment 9

8 years ago
Well as long as Direct2D and directwrite don't cause trouble for Aero in v4, I'm OK with this
No longer blocks: 544820
Duplicate of this bug: 555572
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.