Firefox crashes misses the download manager progress too

RESOLVED DUPLICATE of bug 435799

Status

()

--
major
RESOLVED DUPLICATE of bug 435799
9 years ago
9 years ago

People

(Reporter: deepak.vasudevan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

I was downloading Fedora LiveCD which is about 600 mega bytes in size. Firefox crashed in the middle and restarted. I was expecting the download should be restored. But it is again starting from the fresh. 

The download server seems to be supporting REST (resumed download) so why on earth Firefox download manager not able to restore it? About 300 mega bytes which was downloaded sunk into the drain along with the crashed firefox instance.

Reproducible: Always

Steps to Reproduce:
Unexpected crash of firefox when downloading something
Actual Results:  
Download aborted and restarted from the first.

Expected Results:  
Download should resume from the point of crash instead of restarting from the first.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 435799
You need to log in before you can comment on or make changes to this bug.