Last Comment Bug 569365 - kill preprocessor.pl
: kill preprocessor.pl
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Mitchell Field [:Mitch]
:
Mentors:
: 608234 653409 (view as bug list)
Depends on:
Blocks: 569839
  Show dependency treegraph
 
Reported: 2010-06-01 08:59 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2011-05-16 10:30 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (44.09 KB, patch)
2010-06-03 00:21 PDT, Mitchell Field [:Mitch]
ted: review+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2010-06-01 08:59:17 PDT
Anything that's still using preprocessor.pl should be using Preprocessor.py. We should just switch anything that's left and hg rm it.
Comment 1 Mitchell Field [:Mitch] 2010-06-03 00:21:38 PDT
Created attachment 448963 [details] [diff] [review]
Patch (v1)

This patch removes removes preprocessor.pl from config and js/src/config, and copies Preprocessor.py to the latter.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2010-06-07 08:17:14 PDT
Comment on attachment 448963 [details] [diff] [review]
Patch (v1)

Looks good, thanks.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-11-01 07:10:50 PDT
*** Bug 608234 has been marked as a duplicate of this bug. ***
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-03-22 17:59:06 PDT
http://hg.mozilla.org/mozilla-central/rev/d7692aed054f
Comment 5 Mike Hommey [:glandium] 2011-04-28 05:42:46 PDT
*** Bug 653409 has been marked as a duplicate of this bug. ***
Comment 6 Ted Mielczarek [:ted.mielczarek] 2011-04-28 05:45:04 PDT
Why did this get backed out?
Comment 7 Mike Hommey [:glandium] 2011-04-28 06:11:05 PDT
Seeing http://hg.mozilla.org/mozilla-central/rev/2535ab584956 happening before http://hg.mozilla.org/mozilla-central/rev/bde78741b33b , maybe there were other bustages?
Comment 8 Mike Hommey [:glandium] 2011-05-16 06:57:18 PDT
http://hg.mozilla.org/mozilla-central/rev/e7cf79fd6d32

Needed a copy of Expression.py. (And we don't need to update tools/relic/relic, according to gerv)

Note You need to log in before you can comment on or make changes to this bug.