Browser crashes when loading a page with a Java applet and Java enabled

VERIFIED FIXED

Status

()

Core
Plug-ins
P1
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Richi plana, Assigned: drapeau)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; m18) Gecko/20001016
BuildID:    2000101608

Starting with last Friday's build (2000-10-13), Mozilla crashes when it loads a
page with a Java applet embedded in it (with Java enabled, of course). I noticed
it loading http://www.mozillazine.org/ ... with its banners using Java

Reproducible: Always
Steps to Reproduce:
Enable Java in Edit->Preferences->Advanced ... have the Java 1.3.0 plugin ... Go
to any site with embedded java (ie. http://www.mozillazine.org/ )

Actual Results:  Browser quits ... no core dumped

Expected Results:  Loaded the page and executed the java applet

Comment 1

17 years ago
I've seen a few of these bugs in the unconfirmed state with the general theme
"on Linux, load a page with a java plugin and it crashes every time."  I don't
have a linux box handy so I can't confirm directly, but given the number of
(probable) duplicates, it's safe to say something is seriously wrong with java
applets on linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: rtm
Priority: P3 → P1

Comment 2

17 years ago
I doubt this is av.  Reassigning to George. George, there seem to be many
duplicates of this bug.
Assignee: av → drapeau

Comment 3

17 years ago
shrir, do we have a dupe bug on this?  

Comment 4

17 years ago
Adding George.

Comment 5

17 years ago
Ah, did not realize George already got it.

Comment 6

17 years ago
There are a few bugs filed for this same problem. Hopefully with the new JRE 
bits from Sun, this shud no longer be seen. I will update asap.
(Assignee)

Comment 7

17 years ago
Okay, lemme know if the latest bits work.  I believe they will not work.  The 
reason appears to be a change in the way Java Plug-In on Linux is packaged.  
Minor difference: it was moved into a different directory, and the Netscape 
installer was not notified of the change in directory.  Talking with Java 
Software to see if they can re-package the Linux bits to put Java Plug-In 
(libjavaplugin_oji.so) in the old place.
(Assignee)

Comment 8

17 years ago
Samir's comments on bug 57004 are great info; he found the cause of the problem. 
 This bug depends on that one, I believe.  I'll mark this bug as dependent on 
bug 57004.
Depends on: 57004
Bug 57004 is now FIXED. Has this bug gone away? Richi, can you still reproduce
this bug in today's Mozilla build? If so, please close this as a DUP. If not, we
need to jump on this ASAP as we'd like it fixed for N6 RTM.

Comment 10

17 years ago
I verified  this on today's branch build on linux with the new jre for liux. 
This loads perfectly fine and there is no crash.  
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.