All users were logged out of Bugzilla on October 13th, 2018

"smokescreen" flash emulator doesn't work on m-c or tm tip

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

Attachments

(1 attachment)

BUILD: m-c or tm tip

STEPS TO REPRODUCE:  Load http://smokescreen.us/demos/sb45demo.html

EXPECTED RESULTS: Video, audio, etc

ACTUAL RESULTS: Nothing of the sort, plus an error in the JS console:

  Error: this.enterFrameListeners[b] is not a function
  Source File: http://smokescreen.us/demos/js/smokescreen.0.1.3-min.js
  Line: 383

On m-c the 1-day regression range contains the May 26 tm merge.

On tm, I bisected locally and bisect says:

  The first bad revision is:
  changeset:   41832:b15fd8b568e4
  user:        Andreas Gal <gal@mozilla.com>
  date:        Fri May 07 17:52:52 2010 -0700
  summary:     fast object iteration (558754, r=brendan, CLOSED TREE).

Not sure whether this needs to be an alpha blocker....
(Reporter)

Updated

9 years ago
Blocks: 558754

Updated

9 years ago
blocking2.0: ? → beta1+
Created attachment 448741 [details]
beautified source

Enough delete going on, with plenty of for-in (many with call-free bodies though) that it could be delete inside for-in for the object being enumerated, where the deleted property has not yet been visited. Best to confirm that this is biting.

/be
Duplicate of this bug: 569954
Does this still fail on tm or m-c? Andreas restored delete suppression for the direct object (not for delete on a prototype property, though).

/be
I still get

Error: this.enterFrameListeners[b] is not a function
Source File: http://smokescreen.us/demos/js/smokescreen.0.1.3-min.js
Line: 383

on that URL, with Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100617 Minefield/3.7a6pre

Updated

8 years ago
blocking2.0: beta1+ → beta2+

Updated

8 years ago
blocking2.0: beta2+ → betaN+
Can we get an owner here, please?

Comment 6

8 years ago
I just watched all three strongbad emails without incident.  Good times.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.