If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[HTML5] <h5> inside <button> inside <p> implicitly closes the <p>

RESOLVED FIXED in mozilla2.0b7

Status

()

Core
HTML: Parser
P2
normal
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Assigned: hsivonen)

Tracking

Trunk
mozilla2.0b7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Created attachment 448693 [details]
Testcase

Originally filed as https://bugs.launchpad.net/bugs/588595

The following code:

      <p> <button> <h5>Bar</h5> </button> </p>

results in the following DOM tree:

     <p> <button> </button></p><h5>Bar</h5>  <p></p>

which, of course, renders incorrectly.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100601 Minefield/3.7a5pre

Updated

7 years ago

Comment 1

7 years ago
I'm affected on Ubuntu as well, so this seems to be platform independent:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a5pre) Gecko/20100601 Ubuntu/10.04 (lucid) Minefield/3.7a5pre
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 2

7 years ago
Created attachment 448704 [details]
Actual test case

The test case isn't really a test case for this bug. Attaching a test case.

The behavior (and the spec) here changed at bug 558302 in an effort to match WebKit and IE8 more closely. It appears that spec and parser change didn't quite capture all important aspects of WebKit and IE8 behavior.
Assignee: nobody → hsivonen
Attachment #448693 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 years ago
Spec bug filed http://www.w3.org/Bugs/Public/show_bug.cgi?id=9829
(Assignee)

Updated

7 years ago
Summary: [HTML5] <h5> inside <button> inside <p> handled incorrectly → [HTML5] <h5> inside <button> inside <p> implicitly closes the <p>
(Assignee)

Updated

7 years ago
Blocks: 558302
blocking2.0: --- → ?

Updated

7 years ago
blocking2.0: ? → final+

Updated

7 years ago
Duplicate of this bug: 575244

Updated

7 years ago
Duplicate of this bug: 593114
(Reporter)

Comment 6

7 years ago
Henri, is this invalid HTML?
(Assignee)

Comment 7

7 years ago
(In reply to comment #6)
> Henri, is this invalid HTML?

Not per the current draft, I believe.

It's clear that the parser needs changing. I'll get to it.
(Assignee)

Comment 8

7 years ago
Created attachment 473095 [details] [diff] [review]
Fix implementing spec revision 5158

This patch doesn't have a test case, because bug 559023 will add more than enough <button> test cases.
Attachment #473095 - Flags: review?(jonas)
(Assignee)

Updated

7 years ago
Blocks: 578568
(Assignee)

Updated

7 years ago
Depends on: 559023
Comment on attachment 473095 [details] [diff] [review]
Fix implementing spec revision 5158

rs=me
Attachment #473095 - Flags: review?(jonas) → review+
(Assignee)

Comment 10

7 years ago
http://hg.mozilla.org/mozilla-central/rev/41aaa362225b
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

7 years ago
Marking as in-testsuite?, since the test cases will land as part of bug 559023.
Flags: in-testsuite?
(Assignee)

Comment 12

7 years ago
Test landed as part of bug 559023.
Flags: in-testsuite? → in-testsuite+
Target Milestone: --- → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.